Project

General

Profile

Bug #596

editconf

Added by Phill Stansfeld about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hello,

I am sure this was an intentional new design. Nevertheless, editconf no longer renumbers the first residue back to 1. While not a bug per se this has broken a number of scripts that incorporate gromacs tools, making it difficult for me to upgrade to 4.5.1. If the next release can include an editconf flag that incorporates the "old" renumbering mechanism I would be very grateful.

Thanks & best wishes
Phill

History

#1 Updated by Berk Hess about 9 years ago

You mean keep the old numbering after selected a subgroup
of the system for output?

Berk

#2 Updated by Phill Stansfeld about 9 years ago

(In reply to comment #0)

Hello,

I am sure this was an intentional new design. Nevertheless, editconf no longer
renumbers the first residue back to 1. While not a bug per se this has broken a
number of scripts that incorporate gromacs tools, making it difficult for me to
upgrade to 4.5.1. If the next release can include an editconf flag that
incorporates the "old" renumbering mechanism I would be very grateful.

Thanks & best wishes
Phill

(In reply to comment #1)

You mean keep the old numbering after selected a subgroup
of the system for output?

Berk

Hi Berk,

As far as I am aware this is now what editconf does. ie I export a molecule resid 1292. Instead of renumbering the resid to 1; 1292 is retained.
Trivial, I know.

Thanks & Best wishes,
Phill

#3 Updated by Berk Hess about 9 years ago

I added a -resnr option to editconf for 4.5.3.
I hope this does what you want.

Berk

Also available in: Atom PDF