Project

General

Profile

Bug #599

mdrun minimization crashes with GBSA / HCT and virtual site

Added by michal kolar about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=559)
crashing topology

dear developers,
i minimize protein-ligand complex with gbsa/htc solvent and virtual site. when cut-offs > 0 used, mdrun crashes with f-norm = -nan with both cg and l-bfgs optimizers. topology works fine with still algorithm as well as without any implicit solvent. topology without virtual site also works.

mdrun 4.5.1 is build with gcc-4.4.3, fftw-3.2.2 disabling threads. the error occurs with both single and double precision.

michal kolar

topol.tpr (1.79 MB) topol.tpr crashing topology michal kolar, 10/20/2010 12:30 PM
0.8.gro (213 KB) 0.8.gro input gro michal kolar, 10/21/2010 04:11 AM
min.sol.mdp (802 Bytes) min.sol.mdp input mdp michal kolar, 10/21/2010 04:12 AM
0.8.top (2.91 MB) 0.8.top input top michal kolar, 10/21/2010 09:40 AM

Associated revisions

Revision 8a95cc08 (diff)
Added by Per Larsson about 9 years ago

Added a check in grompp for the case with particles having a non-zero
charge while all GB-parameters are set to zero. This fixes bug #599.

History

#1 Updated by Per Larsson about 9 years ago

Hi!

Could you please provide me with your input .gro and .mdp - files, to speed the resolution of this bug.

Thanks!

#2 Updated by michal kolar about 9 years ago

Created an attachment (id=560)
input gro

#3 Updated by michal kolar about 9 years ago

Created an attachment (id=561)
input mdp

#4 Updated by Per Larsson about 9 years ago

What forcefield did you use?
Since you have the ligand MOL in their, I suspect that is where things go wrong
Could you also upload any changes you have made to the relevant forcefield to get this through pdb2gmx.

Thanks!

#5 Updated by michal kolar about 9 years ago

Created an attachment (id=562)
input top

i use a kind of amber ff03 and gaff mixture which i convert from amber with a simple c code. its more simple than preparing a new residue for pdb2gmx.

#6 Updated by Per Larsson about 9 years ago

Hi!

The reason for this crash is your ET-vsite.
You have set the gb-parameters all to zero, while ET is also having a charge of 0.15325.
This causes problems since the particle will be added to the pairlist for inclusion in the GB-radii calculations, but the all parameters are zero.

I could fix this but introducing a check for this case, which will prevent this situation from happening.
It is not clear to me that vsites should have charges, what is the reason here?

#7 Updated by Per Larsson about 9 years ago

Fixed by adding a check to grompp that covers the case with all GB-parameters set to zero while at the same time having a non-zero charge.

#8 Updated by michal kolar about 9 years ago

thank you, apparently the error was on my side. i didn't think over the gb parameters for charged vsites.
i'm trying to use charged vsite for modelling a bromine atom with a region with a positive electrostatic potential.
but still don't know why it worked for infinite cut-offs...

Also available in: Atom PDF