Project

General

Profile

Bug #615

genion writes a log file

Added by Justin Lemkul almost 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
4.5.3
Affected version:
Difficulty:
uncategorized
Close

Description

Posted to the list, but got no reply:

http://lists.gromacs.org/pipermail/gmx-users/2010-November/055950.html

Looks like the .tpr file is interpreted as being for a simulation instead of just adding ions. This output .log file is useless, and probably would confuse new users so it should be eliminated. Problem is reproducible in 4.5.2 and 4.5.3, but those versions aren't in the list so I indicated git since it's newer than 4.5.1.


Related issues

Related to GROMACS - Feature #1236: deprecate genion non-random insertion of ionsClosed2013-05-01

Associated revisions

Revision 9b57187d (diff)
Added by Pedro Lacerda over 4 years ago

Various fixes for genion

Remove genion non-random insertion of ions, by side effect it stops
writting useless log file. This commit also warns user about -conc
option overriding -nn or -np.

Fixes #1236, #615, and #1208

Change-Id: Icb7e411cda10abb3a7fea4137534f253b0777def

History

#1 Updated by Rossen Apostolov about 6 years ago

  • Description updated (diff)
  • Assignee deleted (Erik Lindahl)
  • Target version deleted (git master)

#2 Updated by Rossen Apostolov over 5 years ago

  • Category changed from mdrun to preprocessing (pdb2gmx,grompp)
  • Priority changed from Normal to Low
  • Affected version - extra info set to 4.5.3

#3 Updated by Mark Abraham over 4 years ago

  • Status changed from New to Accepted
  • Assignee set to Mark Abraham
  • Target version set to 5.0
  • Affected version set to 4.5.3

Writing a .log file is probably an artefact of the genion feature to place ions where the potential suggests. That's been stated as buggy since at least 2006. So I will propose to deprecate that feature, and now it will be trivial to avoid writing a useless .log file for genion.

#4 Updated by Pedro Lacerda over 4 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

#5 Updated by Mark Abraham over 4 years ago

  • Target version changed from 5.0 to 4.6.3

#6 Updated by Teemu Murtola over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF