Project

General

Profile

Bug #635

position restraints output with gmxdump -sys is wrong

Added by Floris Buelens over 6 years ago. Updated 11 months ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
analysis tools
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

gmxdump output for position restraints is incorrect when the option -sys is used. Tested with 4.0.5 and 4.5.3. Steps to reproduce:
wget 'http://www.pdb.org/pdb/download/downloadFile.do?fileFormat=pdb&compression=NO&structureId=1AKI' -O 1AKI.pdb
wget http://www.bevanlab.biochem.vt.edu/Pages/Personal/justin/gmx-tutorials/lysozyme/Files/minim.mdp
pdb2gmx -f 1AKI.pdb -o 1AKI_processed.gro -water spce
editconf -f 1AKI_processed.gro -o 1AKI_newbox.gro -c -d 1.0 -bt cubic
genbox -cp 1AKI_newbox.gro -cs spc216.gro -o 1AKI_solv.gro -p topol.top
[add -DPOSRES]
grompp -f minim.mdp -c 1AKI_solv.gro -p topol.top -o em.tpr
gmxdump -s em.tpr > gmxdump.mdp
gmxdump -sys -s em.tpr > gmxdump_sys.mdp

now gmxdump.mdp has a healthy Position Rest. section starting like this:

Position Rest.:
nr: 2002
iatoms:
0 type=409 (POSRES) 0
1 type=410 (POSRES) 4
2 type=411 (POSRES) 6
3 type=412 (POSRES) 9
4 type=413 (POSRES) 12
5 type=414 (POSRES) 15

and gmxdump_sys.mdp looks like:

Position Rest.:
nr: 2002
iatoms:
0 type=0 (LJ_SR) 0 1
1 type=4 (LJ_SR) 2 6
2 type=3 (LJ_SR) 9 4
3 type=12 (LJ_SR) 5 15
4 type=6 (LJ_SR) 18 7
5 type=22 (LJ_SR) 8 23

The first functype=POSRES entry starts with index 409. With -sys the entries start from type 0 and the whole section is messed up.

Associated revisions

Revision ced146e9 (diff)
Added by Mark Abraham over 4 years ago

Noting that and why gmxdump -s -sys is broken

Not worth fixing. You could pass a boolean from gmxdump
into the set_posres_params to avoid executing the
problematic line, but that would hit a lot of
other code paths that also call gmx_mtop_to_t_topology.

Refs #635

Change-Id: I308e59287dc578b95ea67c313867df3e75047fa4

History

#1 Updated by Floris Buelens about 6 years ago

commenting out this line:

/* Set the parameter index for idef->iparams_posre */
il->iatoms[i*2] = i;

in mtop_util.c seems to fix gmxdump -sys functionality but I would guess this has some knock-on effects...?

#2 Updated by Rossen Apostolov almost 6 years ago

  • Assignee set to Berk Hess
  • Target version changed from 4.5.1 to 4.5.5

#3 Updated by Szilárd Páll over 5 years ago

  • Target version changed from 4.5.5 to 4.5.6

#4 Updated by Mark Abraham over 4 years ago

  • Category set to analysis tools
  • Status changed from New to Feedback wanted
  • Target version changed from 4.5.6 to future

I made https://gerrit.gromacs.org/2035 to note that this bug exists and comment where the code is that triggers it. But with the likelihood of massive code changes, and the low impact of the bug, it is not worth fixing.

#5 Updated by Rossen Apostolov over 3 years ago

  • Status changed from Feedback wanted to Rejected
  • Affected version set to 4.5.3

As Mark pointed out, it's not worth fixing, thus closing the report.

#6 Updated by Mark Abraham 11 months ago

  • Target version deleted (future)

Also available in: Atom PDF