Project

General

Profile

Bug #688

grompp frame selection

Added by R. Bryn almost 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I am not sure if this is a bug or a feature, however, I have been trying to minimize all the frames in a pdb trajectory. With grompp I have tried using -s trajectory.pdb -time %i, where %i is incremented over all the frames with a python script. It seems that the -time option does not work with a pdb trajectory file. Is this the expected behavior? I have gone around the problem by using trjconv to first extract the frame that I want with -dump.

Thanks,

Associated revisions

Revision 508bbdd8 (diff)
Added by Mark Abraham almost 9 years ago

Improved grompp documentation

Added clarification points about whether coordinates come from -t or -c
files, reworded the recommendations about restarts, and added a tip
that gmxcheck can compare .tpr files.

IssueID #688

History

#1 Updated by Justin Lemkul almost 9 years ago

R. Bryn wrote:

I am not sure if this is a bug or a feature, however, I have been trying to minimize all the frames in a pdb trajectory. With grompp I have tried using -s trajectory.pdb -time %i, where %i is incremented over all the frames with a python script. It seems that the -time option does not work with a pdb trajectory file. Is this the expected behavior? I have gone around the problem by using trjconv to first extract the frame that I want with -dump.

This is not a bug, as such. The -c flag (which I assume is what you meant, not -s) takes a coordinate file, not a trajectory, per the grompp documentation. The -time option operates on trajectories (option -t). It is true that you cannot choose a specific timeframe from a .pdb trajectory, but this was not intended.

#2 Updated by Mark Abraham almost 9 years ago

I would expect grompp -f em.mdp -c conf.pdb -time 100 -f conf.pdb to do what R. Bryn wants.

-c supplies things like atom and residue names to cross-check with the topology. -f supplies coordinates and such, and only in its absence are they taken from the -c file. I've updated the grompp inline documentation to help clarify this and other points.

#3 Updated by Rossen Apostolov about 8 years ago

  • Status changed from New to Closed
  • Assignee deleted (Erik Lindahl)

Please reopen if needed but as Mark says, it's not really a bug.

Also available in: Atom PDF