Project

General

Profile

Bug #71

grompp takes excessive time for large systems

Added by David van der Spoel over 13 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
High
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

grompp takes excessively long time for large systems when virtual sites are present.

History

#1 Updated by David van der Spoel over 13 years ago

Times up to 45 minutes for a 300,000 atom system.

#2 Updated by David van der Spoel almost 13 years ago

Now it may be even worse because the old topologies can not be reproduced
anymore (something wrong with gen_sblock). Unfortunately these changes are in
CVS already!

#3 Updated by David van der Spoel over 12 years ago

The message is because your box is zero. Maybe there should be an exemption for
that. I've implemented that in CVS now.

Note that some analysis tools assume you have periodic boundary conditions.

#4 Updated by David van der Spoel over 12 years ago

Previous message was intended for another bug 117.

#5 Updated by David van der Spoel about 12 years ago

Finally recoded the whole she-bang such that it seems to work now. That means splitting topologies and generating shake blocks. Part of the speed issue has been tackled by Berk in 4.0, but an optimization of the convparm code is still needed.

Also available in: Atom PDF