Project

General

Profile

Bug #725

Four letter residues and default index groups

Added by Daniel Larsson over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
4.5.3
Affected version:
Difficulty:
uncategorized
Close

Description

Some forcefields have residues with 4 letters, e.g. amber with N- and C-terminals prepended with an N or a C.

Pdb files written by gromacs tools only write 3 letters. These files are incorrectly parsed by make_ndx and other tools that construct the default index groups. The N- and C-terminal residues are not recognized as being part of a protein.

Either these residues should be written with all four letters (my suggestion, since column 21 in the PDB file format standard is not defined: http://www.wwpdb.org/documentation/format32/sect9.html) or the routine that generate the default groups should be made more intelligent to recognize these as being residues.


Related issues

Related to GROMACS - Bug #779: PDB files use incorrect namesClosed2011-07-13

Associated revisions

Revision 43a02a47 (diff)
Added by Erik Lindahl over 3 years ago

Enable 4-letter resname in PDB output, keeps more pdbinfo.

This still fully adheres to the PDB standard since column 21
is not used by the standard. All common programs (PyMol, VMD, etc)
understand the 4-letter format, and programs that only read three
letters will still read the same filename as they used to. In
particular, this conserves most residue names during pdb<->gro
format conversions. We have also killed the non-standard
wide pdb format to avoid writing broken PDB files.

Fixes #725. Refs #917.

Change-Id: I9b6b8f2e191acdfb65ca2b5d96f39249cd71ea98

History

#1 Updated by Roland Schulz about 5 years ago

  • Priority changed from Normal to Low

I think this is a feature request not a bug and thus I change the priority to low.

#2 Updated by Erik Lindahl over 3 years ago

  • Category set to preprocessing (pdb2gmx,grompp)
  • Assignee set to Erik Lindahl
  • Target version set to 5.0
  • Affected version set to 4.6

This is not really a bug but a limitation of the PDB format; we've never claimed to write more than 3 letters. Since Gromacs-4.6 uses our new force field setup (that does not rely on 4-letter amino acid names in PDB files) that particular problem is no longer a concern, but I'll try to add 4-letter residue names in PDB output for Gromacs-5.0.

#3 Updated by Gerrit Code Review Bot over 3 years ago

Gerrit received a related patchset '1' for Issue #725.
Uploader: Erik Lindahl ()
Change-Id: I9b6b8f2e191acdfb65ca2b5d96f39249cd71ea98
Gerrit URL: https://gerrit.gromacs.org/3481

#4 Updated by Erik Lindahl over 3 years ago

  • Status changed from New to Fix uploaded

#5 Updated by Erik Lindahl over 3 years ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Erik Lindahl over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF