Project

General

Profile

Bug #762

Truncating files: fopen in append mode doesn't guarantee file pointer at end

Added by Roland Schulz over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

fopen in append mode doesn't guarantee file pointer to be at end of file before data is written to file. This can cause file to be truncated because the file position can be 0 in checkpoint file. Could be the cause of http://lists.gromacs.org/pipermail/gmx-users/2011-June/062006.html

Associated revisions

Revision 5b3e7504 (diff)
Added by Roland Schulz about 8 years ago

Make sure that ftell works correctly for files opened in append mode
fixing Issue #762

Change-Id: I019fa6a2b51a2156c900e1a31a0b521e62b79961

Revision 7d54797b
Added by Berk Hess about 8 years ago

Merge "Make sure that ftell works correctly for files opened in append mode fixing Issue #762" into release-4-5-patches

History

#1 Updated by Roland Schulz about 8 years ago

solution at https://gerrit.gromacs.org/43. submitted to release-4-5-patches

#2 Updated by Roland Schulz about 8 years ago

  • Status changed from New to 3

#3 Updated by Rossen Apostolov about 8 years ago

  • Status changed from 3 to Closed

Also available in: Atom PDF