Project

General

Profile

Bug #795

mdrun segfaults for npme > np

Added by Carsten Kutzner about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Low
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Currently, Gromacs 4.5.4 gives a segfault if one runs mpirun -np 8 mdrun_mpi -npme 120 with no warning of the source of the problem. Obviously npme>nnodes is a bad setup, but a check would be nice.

The cause for this behavior is:
cr->npmenodes is set in mdrun.c right after the command line args are parsed, and in the code there is also a comment that npme>nnodes should not
cause a problem at that point.

However, if npme>nnodes, in init_domain_decomposition / dd_choose_grid / optimize_ncells the number of pp nodes = nnodes-npme turns out to be negative such that in factorize the memory allocation does not work.

Associated revisions

Revision e230816f (diff)
Added by Carsten Kutzner about 8 years ago

Instead of a segv, mdrun now gives an error msg if npme>np, fixes #795

Instead of a segv, mdrun now gives an error msg if npme>np, fixes #795

Change-Id: I2e93bccf45ace215d6237354559b8750628a13d6

History

#1 Updated by Carsten Kutzner about 8 years ago

  • Status changed from New to 3
  • % Done changed from 0 to 100

I have added appropriate checks in domdec_setup.c

#2 Updated by Carsten Kutzner about 8 years ago

  • Status changed from 3 to Closed

Also available in: Atom PDF