Project

General

Profile

Bug #824

pdb2gmx does not generate cmap entries for alanine dipeptide

Added by Cesar Luis Avila about 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

While processing a pdb containing the alanine dipeptide (ALAD), pdb2gmx does not generate the cmap entry in the topology file, although it is listed on the RTP.

aladipep.pdb (1.54 KB) aladipep.pdb Alanine dipeptide (charmm ff) Cesar Luis Avila, 04/12/2012 10:41 AM
aladipep.pdb (1.75 KB) aladipep.pdb Cesar Luis Avila, 04/12/2012 02:36 PM

Associated revisions

Revision 41c86c01 (diff)
Added by Erik Lindahl over 3 years ago

Fixed CMAP generation for alanine dipeptide special residue

Fix CMAP to work for residues not detected as proteins, and
make sure we correctly process single-residue entries that
have residue-internal CMAP definitions. In particular, this
is important for the default alanine dipeptide special
residues (ALAD) in Charmm27.

Fixes #824.

Change-Id: I5538b26175f12dcac983491323b5b6ee303c8434

History

#1 Updated by Roland Schulz about 6 years ago

  • Status changed from New to Feedback wanted

As you wrote on the mailing-list, all CMAP entries refer to the previous and the next residue. Thus no matching entry exists for a di-peptide. Should a di-peptide have a CMAP entry?

#2 Updated by Justin Lemkul about 6 years ago

Roland Schulz wrote:

As you wrote on the mailing-list, all CMAP entries refer to the previous and the next residue. Thus no matching entry exists for a di-peptide. Should a di-peptide have a CMAP entry?

In aminoacids.rtp of the latest charmm27.ff (in release-4-6), there is an alanine dipeptide (ALAD) entry, which has a [cmap] directive. Is the directive somehow not working, or is your input specifying something else?

#3 Updated by Cesar Luis Avila about 6 years ago

Justin:
pdb2gmx is using the default value -cmap yes, so I think the directive is not working.

Roland
CMAP was parametrized with alanine dipeptide (MacKerell 2004), so you must provide a cmap entry to reproduce the results.

#4 Updated by Rossen Apostolov about 6 years ago

Added Par to the watchers list since he implemented CMAP

#5 Updated by Pär Bjelkmar almost 6 years ago

Nice, you seem to be on top of this. Cesar, could you please send me/post your input file and specify which gromacs version you're running?

Rossen Apostolov wrote:

Added Par to the watchers list since he implemented CMAP

#6 Updated by Rossen Apostolov over 5 years ago

Cesar, do you still have that problem?

#7 Updated by Cesar Luis Avila over 5 years ago

I haven't tried it with latest gromacs versions. I am attaching the pdb file so that it can be tested.

#8 Updated by Rossen Apostolov over 5 years ago

dialanine is actually a special case and you'll need to use ALAD as the residue name. have a look at charmm27.ff/aminoacids.rtp because the atom names are also a little different.

#9 Updated by Cesar Luis Avila over 5 years ago

Sorry, my mistake. I took the file from the wrong folder. This is the one that I was using as input for gromacs.

#10 Updated by Rossen Apostolov over 5 years ago

src/kernel/pdb2top.c says:

/* End loop at nres-1, since the very last residue does not have a +N atom, and * therefore we get a valgrind invalid 4 byte read error with atom am */
for(residx=0; residx<nres-1; residx++)
...

In your case there is only 1 residue, and that's why it fails. I'm not sure what's the proper way to work with that case.

#11 Updated by Teemu Murtola almost 5 years ago

  • Status changed from Feedback wanted to New

Changed the status back to new as it seems that there is a problem. But it is still a bit unclear how well the underlying problem has been identified.

#12 Updated by Erik Lindahl over 3 years ago

  • Affected version set to 4.6

Neither of the two files uploaded by Cesar represent an alanine dipeptide - there is just a single CA atom.

#13 Updated by Erik Lindahl over 3 years ago

Never mind, it helps to read the text first. The second file is fine.

#14 Updated by Gerrit Code Review Bot over 3 years ago

Gerrit received a related patchset '1' for Issue #824.
Uploader: Erik Lindahl ()
Change-Id: I5538b26175f12dcac983491323b5b6ee303c8434
Gerrit URL: https://gerrit.gromacs.org/3665

#15 Updated by Erik Lindahl over 3 years ago

  • Status changed from New to Resolved

#16 Updated by Erik Lindahl over 3 years ago

  • Status changed from Resolved to Fix uploaded

#17 Updated by Gerrit Code Review Bot over 3 years ago

Gerrit received a related patchset '1' for Issue #824.
Uploader: Rossen Apostolov ()
Change-Id: Ifd92947c41a2498ec57e09dce8a8f1c0db2aeff4
Gerrit URL: https://gerrit.gromacs.org/3677

#18 Updated by Teemu Murtola over 3 years ago

  • Category set to preprocessing (pdb2gmx,grompp)
  • Assignee set to Erik Lindahl
  • Target version set to 5.0

#19 Updated by Roland Schulz about 3 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF