Project

General

Profile

Bug #833

NUMA should probably not be used under Cygwin

Added by Mark Abraham over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Patch 41fc4e43 apparently provided by Scott Field assumes that NUMA can be used under Cygwin. I have been able to find no evidence that it should. AFAIK pthreads should be fine under Cygwin.

Secondarily, src/gmxlib/thread_mpi/numa_malloc.c and include/thread_mpi/numa_malloc.h use some compiler flags to select whether to try to use NUMA, rather than the results of tests. Such tests only exist for CMake anyway, which raises the question why new functionality was added to the 4.5.5 release.

To resolve, I suggest changing the sense of the CYGWIN-related preprocessor conditionals in the above files. I'm happy to do this and test (so that we actually get some quality-assurance for 4.5.6), but perhaps this should be bounced to Scott for feedback.

Associated revisions

Revision 0d2eef68 (diff)
Added by Mark Abraham almost 5 years ago

Permit threads build on Cygwin

Fixes #833
Change-Id: I1429629417132c164e9b017721c0035583d7d6bf

Revision 97bcc5be (diff)
Added by Mark Abraham almost 5 years ago

Added Windows-specific #defines, and use them

The lack of an elegant way to code "do this on Windows/
Cygwin/whatever" may have contributed to 4.5.5 not compiling with
threading under Cygwin (IssueID #833, which was fixed elsewhere).

Change-Id: I07fa69825181e2b04cb89798898898f1d258d371

Revision f57ec1b0 (diff)
Added by Mark Abraham almost 5 years ago

Continuing to fix threading on Cygwin

Fixes #833

Change-Id: I5d577a149ad18b295559f6d87c24dc42bffd281e

History

#1 Updated by Rossen Apostolov almost 5 years ago

  • Assignee set to Mark Abraham
  • Target version set to 4.5.6

Yes, please check with Scott

#2 Updated by Mark Abraham almost 5 years ago

Sander's commit (hash above) was based on things Scott provided, but I'm not going to contact Scott when I think the issue is likely to be Sander's apparently mistaken assumption that NUMA is available under Cygwin. If we're not likely to hear from Sander, then I think the fix in https://gerrit.gromacs.org/#/c/704/ resolves this issue.

#3 Updated by Rossen Apostolov almost 5 years ago

  • Status changed from New to Closed

Also available in: Atom PDF