Project

General

Profile

Bug #878

unify GROMACS header printing

Added by Arthur Zalevsky over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Affected version - extra info:
4.5.4
Affected version:
Difficulty:
uncategorized
Close

Description

OS: Ubuntu 11.10 x86
Package: gromacs-4.5.4 from distro repos

Most utilites prints GROMACS header ( text begins with :-) G R O M A C S (-: ) to STDERR, but some to STDOUT.
That creates some inconveniences while scripting. Unifying of their behavior seems logical.

Utilites which print header to STDOUT:
g_hbond, g_hbond_d, g_x2top, g_x2top_d, gmxcheck, gmxcheck_d, grompp, grompp_d, ngmx, ngmx_d, tpbconv, tpbconv_d

stdout (23.5 KB) stdout Output print test Arthur Zalevsky, 02/02/2012 02:42 PM

Associated revisions

Revision 26bd5f7a (diff)
Added by Roland Schulz about 7 years ago

Build man-pages instead of distributing them in the source

One less thing to do manual for releasing the code. And thus
avoiding to accidental releasing which old version of man-pages.

Writing copyright notice to stderr for all programs (was inconsistent)
and caused copyright notice to be displayed during build.

The CPack source package continues to contain the man pages pre-build.
CPack verifies that they are genenerated before building the source
package.

Added .isreposource to distinquish code obtained from git from code
downloaded as CPack source package.

Related to #645, #854, #735
Fixes #878

Change-Id: I7d7145fb99d3f1991d0f3992ca4f3ea20668dd9a

History

#1 Updated by Rossen Apostolov over 7 years ago

  • Assignee set to Rossen Apostolov
  • Target version set to 4.5.6

#2 Updated by Teemu Murtola about 7 years ago

Has been fixed (by the linked commit) in release-4-6, but target version is set to 4.5.6. The fix should be either backported or the target version updated.

#3 Updated by Roland Schulz almost 7 years ago

  • Status changed from New to Closed
  • Target version changed from 4.5.6 to 4.6

I don't think it needs to go into 4.5.6. Please revert change of target version if you disagree.

Also available in: Atom PDF