Project

General

Profile

Bug #9

mdrun exits on reading tpr files for >1 CPU on linux pc

Added by Carsten Kutzner almost 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Successfully installed Gromacs 3.3rc1 on 2.4.21 linux. Single processor tpr
files run as expected. When running mdrun in parallel, it always crashes
with errors like:

Reading file ../TEST.tpr, VERSION 3.3_rc1 (single precision)
-------------------------------------------------------
Program mdruncvs, VERSION 3.3_rc1
Source code file: block_tx.c, line: 74

Fatal error:
0: size=4, len=12, rx_count=0

-------------------------------------------------------
(Size and len vary depending on tpr file used)

Reading file ../AP-100steps-04s.tpr, VERSION 3.2.90_beta_20040828 (single precision)
-------------------------------------------------------
Program mdrun, VERSION 3.3_rc1
Source code file: symtab.c, line: 108

Fatal error:
symtab get_symtab_handle 81527 not found
-------------------------------------------------------

- gmx configure flags --enable-mpi --without-x --disable-x
- LAM 7.1.1
- AMD Athlon dual proc
- gcc version 3.3.1, gnu c lib 2.3.3
- tried both the cvs version and the gmx 3.3rc1 tar file
- tested 3 different systems / input tpr files

guanylin-02.tpr (729 KB) guanylin-02.tpr tpr file of guanylin test system for 2 CPUs Carsten Kutzner, 09/06/2005 02:00 PM

History

#1 Updated by Carsten Kutzner almost 14 years ago

Created an attachment (id=1)
tpr file of guanylin test system for 2 CPUs

try something like
mpirun -np 2 ~/gromacs-3.3_rc1/src/kernel/mdrun -s ../guanylin-02.tpr

#2 Updated by Erik Lindahl almost 14 years ago

This is caused by an error in the QM-MM group communication. Will fix!

#3 Updated by Erik Lindahl almost 14 years ago

The QM group data were send after the annealing data, but received before.

Also available in: Atom PDF