Project

General

Profile

Bug #901

Dispersion correction incorrect with energy minimization

Added by David van der Spoel over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The dispersion correction term is multiplied by the number of processors in parallel energy minimization runs. This could be due to the fact that term is summed into the potential energy before evaluating global_stat in the function evaluate_energy in minimize.c. Since this does not affect the minimization it is not very important, but as soon as force fields start to reproduce meaningful energies it will be important.

Associated revisions

Revision c19645bf (diff)
Added by Berk Hess over 7 years ago

fixed dispersion correction with parallel EM

With EM the energy and pressure dispersion correction terms
were multiplied by the number of nodes. Fixes #901

Change-Id: I289ac0de7d7a9c1f72e939b840c549c1cb49a52a

History

#1 Updated by Rossen Apostolov over 7 years ago

Do we want this fixed for 4.5.6?

#2 Updated by David van der Spoel over 7 years ago

  • Status changed from New to Closed

Fixed in commit I289ac0de.

Also available in: Atom PDF