Project

General

Profile

Bug #968

Memory error with complex boolean selections

Added by Teemu Murtola about 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
selections
Target version:
Affected version - extra info:
4.5-4.5.5
Affected version:
Difficulty:
uncategorized
Close

Description

Complex boolean selections that contain static subexpressions may result in reallocation of memory to which a pointer is retained elsewhere. This leads to crashes or other unpredictable behavior. Example of a selection that causes problems is atomnr 1 to 4 or (atomnr 4 to 6 and (atomnr 5 to 7 or x < 2)).

The problem is fixed in master by dd3a102, which should be backported to release-4-5-patches.

Associated revisions

Revision b7b531f3 (diff)
Added by Teemu Murtola about 5 years ago

Fix memory error with complex boolean selections.

Backported from dd3a102.

Conflicts:
src/gmxlib/selection/compiler.c

Fixes #968.

Change-Id: If92b5b1eb8cf6b3acb510ba43f64fc82b63ab82a

History

#1 Updated by Teemu Murtola about 5 years ago

  • Status changed from New to Closed
  • Affected version - extra info set to 4.5-4.5.5

#2 Updated by Teemu Murtola about 4 years ago

  • Category changed from analysis tools to selections
  • Affected version set to 4.5.5

Also available in: Atom PDF