Project

General

Profile

Bug #97

pdb2gmx produces unusable ARGN

Added by Erik Marklund over 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
High
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Neutralizing arginines (ARGN) with virtual sites in pdb2gmx generates
constraints between CZ and HH1. Such constraints have no parameters, grompp sets
them to zero length and gives warnings, and mdrun subsequently crashes.

1UBQ.pdb (58.8 KB) 1UBQ.pdb Ubiquitin. Makes faulty top-file. Erik Marklund, 04/16/2007 11:02 AM

History

#1 Updated by David van der Spoel almost 13 years ago

Hi Erik,

could you please upload an exampl pdb file and command line?

#2 Updated by Erik Marklund almost 13 years ago

Created an attachment (id=144)
Ubiquitin. Makes faulty top-file.

#3 Updated by Erik Marklund almost 13 years ago

I can't remember exactly which files I used or exaclty what I dit, but I managed
to reproduce the error in the following way:

pdb2gmx -f 1UBQ.pdb -o tst -i tst -p tst -arg -vsite hydrogens

I chose the OPLS-force field and set the arginines to neutral.
From the gro-file tst.gro:
...
42ARGN CZ 737 2.713 3.242 2.657
42ARGN NH1 738 2.763 3.366 2.646
42ARGN HH1 739 2.690 3.432 2.660
42ARGN NH2 740 2.581 3.230 2.673
42ARGN HH21 741 2.539 3.139 2.675
42ARGN HH22 742 2.524 3.311 2.683
...

From the constraint section of tst.top:
...
737 739 2
...

Running grompp afterwards yields a bunch of warnigs about the constraints:
grompp -f vacuumsim/em.mdp -c tst.gro -p tst.top -o grompp_tst -po grompp_tst
...
WARNING 2 [file "tst.top", line 2706]:
No default Constr. No Conn. types, using zeroes
WARNING 3 [file "tst.top", line 2731]:
No default Constr. No Conn. types, using zeroes
WARNING 4 [file "tst.top", line 2782]:
No default Constr. No Conn. types, using zeroes
WARNING 5 [file "tst.top", line 2789]:
No default Constr. No Conn. types, using zeroes
...
(Warning 1 arose from using a slightly unsuiting mdp-file for this test case and
shouldn't affect the problem with the constraints.)

I didn't try starting the simulation this time, since I'm quite convinced it'll
crash.

All of the above was done using gromacs 3.3.2b. I'll upload the pdb-file.

#4 Updated by David van der Spoel over 12 years ago

This will be fixed automagically when you build the new genvsite algorithms. It could also be resolved by simply adding a distance to the ffoplsaabon.itp similar to the other constraint lengths that are there.

Also available in: Atom PDF