Project

General

Profile

Bug #993

Shell code in single precision gives non-reproducible forces

Added by Roland Schulz about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

For the complex/sw test adding reference values for the forces causes it to be non-reproducible between different build configurations. See https://gerrit.gromacs.org/#/c/1259/ for details. It should be checked whether that is a caused by some bug in the code or whether it is expected. If it is expected the test should be adapted. For now the test doesn't has reference values for single precision forces (and thus the forces aren't tested).

Associated revisions

Revision f1b89b02 (diff)
Added by Roland Schulz about 7 years ago

Check forces for all tests

Forces wasn't written out for most tests and thus not tested.
Reference values are generated with 4.5.5

The complex/sw/reference_s.trr still does not contain
forces because of #993.

Change-Id: I8908ea9d97ae5b0ef018d13aee99fb09f5087bfd

History

#1 Updated by Szilárd Páll about 7 years ago

  • Category set to mdrun
  • Target version set to 4.6

#2 Updated by Roland Schulz almost 7 years ago

  • Status changed from New to Closed

As David explains in 1259 it is most likely a change in order. We should have better tests to also be able to test single precision but that doesn't require its own redmine issue.

Also available in: Atom PDF