Project

General

Profile

Bug #999

add MYLIB_EXPORT for public API

Added by Roland Schulz about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

MYLIB_EXPORT should be added to the function declaration of all public functions. Without it we can't compile shared libraries on Windows. See http://www.cmake.org/Wiki/BuildingWinDLL. And this causes the Windows binaries to be huge compared to the Linux binaries (compressed 60MB versus 7MB).


Related issues

Related to GROMACS - Task #988: Definition of "public API"New
Is duplicate of GROMACS - Task #701: Add symbol visibility macrosNew

History

#1 Updated by Teemu Murtola about 7 years ago

Duplicate of #701. Also needs some discussion on #988.

#2 Updated by Roland Schulz about 7 years ago

  • Status changed from New to Closed

Closed as duplicate.

Also available in: Atom PDF