Project

General

Profile

Bug #110

Shake block crossing node boundaries

Added by Jianhui Tian about 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
High
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I am running a water/AOT reverse micelle/Isooctane system. The total atom
number is 41688. I am running it with two processors on a single machine of the
clusters, the system information 2005 x86_64 x86_64 x86_64 GNU/Linux.

The error code are like following:
The gromacs version is 3.3.1.
_______________________________________________________________________
Checking consistency between energy and charge groups...
Calculating fourier grid dimensions for X Y Z
Using a fourier grid of 72x72x72, spacing 0.119 0.119 0.119
splitting topology...
Walking down the molecule graph to make shake-blocks
There are 23940 charge group borders and 25604 shake borders
There are 23940 total borders
Division over nodes in atoms:
20844 20844
-------------------------------------------------------
Program grompp_d, VERSION 3.3
Source code file: splitter.c, line: 121

Fatal error:
Shake block crossing node boundaries
constraint between atoms (20836,20844)
-------------------------------------------------------
_______________________________________________________________________
I also tried to run it with 3, 4 and 5 processors, and they all had the same
problem "Shake block crossing node boundaries". I checked the atoms, they are
not bound to each other with H-bond directly.

md.mdp (1.05 KB) md.mdp The run input file Jianhui Tian, 10/06/2006 08:56 PM
aotwatict14_min1.gro (1.79 MB) aotwatict14_min1.gro Coordinates file Jianhui Tian, 10/06/2006 08:57 PM
aotsys_14.top (352 Bytes) aotsys_14.top Topology file Jianhui Tian, 10/06/2006 08:57 PM
ffamber_aot.itp (28.4 KB) ffamber_aot.itp Topology file Jianhui Tian, 10/06/2006 08:58 PM
ffamber_ict.itp (10.4 KB) ffamber_ict.itp Tpopology file Jianhui Tian, 10/06/2006 08:58 PM
ffamber99nb.itp (6.57 KB) ffamber99nb.itp L_J parameter Jianhui Tian, 10/11/2006 12:25 AM
parabug.tar.gz (629 KB) parabug.tar.gz all the file for running Jianhui Tian, 10/17/2006 05:40 PM

History

#1 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=89)
The run input file

#2 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=90)
Coordinates file

#3 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=91)
Topology file

#4 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=92)
Topology file

#5 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=93)
Tpopology file

#6 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=96)
L_J parameter

At the end of this ffamber99nb.itp is the L-J parameters for my molecules.

#7 Updated by David van der Spoel about 13 years ago

There are at least two input files missing.

Please upload the whole bunch as one tar.gz file

#8 Updated by Jianhui Tian about 13 years ago

Created an attachment (id=97)
all the file for running

#9 Updated by David van der Spoel over 12 years ago

You have a problem in your topology. You should have all the charge groups
sequentially. That is, you must have the atoms of e.g. charge group 18 after
each other. However this does not cause the problem. The problem is that the
constraint groups are completely uncoupled from the charge groups. If you change
constraints h-bonds to all-bonds in your mdp file it does work. on up to 12
processors. While grompp should be able to detect this condition, I will not fix
this, because in 4.0 we will completely change the structure anyway.

Also available in: Atom PDF