Project

General

Profile

Bug #112

negative eigenvalues from g_covar

Added by Alexandra Patriksson about 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I am running mass weighted g_covar on a 100ns trajectory of a small protein with
304 atoms. Independent of what parts of the protein that a choose to analyse
(Ca, protein-H, the entire protein etc.) I get a number of negative eigevalues
at the very end of the file...

My command looks like:

g_covar -f -s -o -v -av -l -n -mwa -tu

If I run the analysis on the whole protein, I get 912 eigenvalues of which 10
are negative. If I run using Protein-H, I get 462 eigenvalues of which 7 are
negative. And if I run it using Ca atoms only (20 atoms giving 60 eigenvalues),
I get 5 negative.

History

#1 Updated by Erik Lindahl about 13 years ago

To determine if this is caused by the diagonalization, please try running it with an earlier version of
Gromacs that uses the built-in QL77 solver instead of LAPACK. That would be any version released before
2005-02-02 (e.g. 3.2.1).

If that does not produce any negative eigenvalues, the next step would be to run the latest version, but
linking with external LAPACK/BLAS instead of the built-in versions.

Cheers,

Erik

#2 Updated by Alexandra Patriksson about 13 years ago

Running version 3.2.1 did only make it even worse I would say... But, running
the 3.3-version of g_covar_d seems to help. Now I only get three negative
eigenvalues if I use Protein-H, and they all belong to the translational and
rotational modes. Also, the negative eigenvalues are now so small, 10^-15, that
they can be approximated by 0.

(In reply to comment #1)

To determine if this is caused by the diagonalization, please try running it

with an earlier version of

Gromacs that uses the built-in QL77 solver instead of LAPACK. That would be

any version released before

2005-02-02 (e.g. 3.2.1).

If that does not produce any negative eigenvalues, the next step would be to

run the latest version, but

linking with external LAPACK/BLAS instead of the built-in versions.

Cheers,

Erik

#3 Updated by Erik Lindahl about 13 years ago

Sounds like an accuracy-dependent issue rather than a bug then. Still, before I close the bug, could you
update the files to reproduce it? It might help us improve accuracy (or do part in double) for future
versions.

#4 Updated by David van der Spoel almost 13 years ago

This was caused by single precision and the negative eigenvalues were on the
precision limit compared to the other ones.

Also available in: Atom PDF