Project

General

Profile

Bug #1266

Affinity setting not supported on Cray XK7

Added by Szilárd Páll over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The Cray programming environment (xt-asyncpe) somewhere between the version 5.17(5.18?) and 5.20 versions broke mdrun-s affinity setting capabilities - at least that's what the warning message appearing in the stderr and log suggests.

The behavior was observed on Toedi, the Cray XK7 at CSCS.

Note that by default aprun sets thread affinites (the default is -cc cpu), but this results in poor performance. Previously, the -cc none setting has been used to disable the aprun-set affinities and rely on the affinity set by mdrun.


Related issues

Is duplicate of GROMACS - Bug #1270: affinity setting broken with MPIClosed

History

#1 Updated by Szilárd Páll over 6 years ago

Note that based on performance observed earlier, I suspect that already Cray runtimes preceding xt-asyncpe 5.17 were perhaps silnetly ignoring affinity settings. I'm not entirely sure, I'll have to dig up some old log files and redo the runs with affinities set through aprun which seems to work; e.g. for a Cray XK7 with a single Interlagos CPU per rank, running 4 ranks with 4 threads each getting the otherwise default mdrun affinity requires aprun -cc 0,1,2,3:4,5,6,7:8,9,10,11:12,13,14,15.

#2 Updated by Szilárd Páll over 6 years ago

ACtually this is a duplicate of #1270. Is it not possible to mark it as such?

#3 Updated by Rossen Apostolov over 6 years ago

Marked as such.

When a related issue is added there is a dropdown list that has "duplicate" in it.

#4 Updated by Szilárd Páll over 6 years ago

Rossen Apostolov wrote:

Marked as such.

When a related issue is added there is a dropdown list that has "duplicate" in it.

Thanks.

#5 Updated by Mark Abraham over 6 years ago

  • Status changed from New to Fix uploaded
  • Target version set to 4.6.3

#6 Updated by Mark Abraham over 6 years ago

  • Status changed from Fix uploaded to Resolved

#7 Updated by Szilárd Páll about 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF