Project

General

Profile

Bug #1305

nonbonded interaction warning message has a printf typo

Added by Chris Neale over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Quick description:

The following warning should probably be listing %3f. not 3f:

"WARNING: Listed nonbonded interaction between particles 1 and 183
at distance 3f which is larger than the table limit 3f nm."

Longer description:

I have a system with a protein and one water molecule. If I decouple the water molecule like this:

free-energy = yes
init-lambda = 1
couple-lambda0 = vdw-q
couple-lambda1 = none
couple-intramol = no
couple-moltype = SOL

Then everything works OK. However, if I use this instead:

couple-moltype = Protein

Then I can not use multiple nodes:

Fatal error:
There is no domain decomposition for 16 nodes that is compatible with the given box and a minimum cell size of 9.91526 nm
Change the number of nodes or mdrun option -rdd or -dds
Look in the log file for details on the domain decomposition
For more information and tips for troubleshooting, please check the GROMACS
website at http://www.gromacs.org/Documentation/Errors

If, however, I do use a single node then I get the following warning:

WARNING: Listed nonbonded interaction between particles 1 and 183
at distance 3f which is larger than the table limit 3f nm.

This is likely either a 1,4 interaction, or a listed interaction inside
a smaller molecule you are decoupling during a free energy calculation.
Since interactions at distances beyond the table cannot be computed,
they are skipped until they are inside the table limit again. You will
only see this message once, even if it occurs for several interactions.

IMPORTANT: This should not happen in a stable simulation, so there is
probably something wrong with your system. Only change the table-extension
distance in the mdp file if you are really sure that is the reason.

History

#1 Updated by Justin Lemkul over 6 years ago

Duplicate of #1163

#2 Updated by Rossen Apostolov almost 6 years ago

  • Status changed from New to Closed

fixed in 8f16a532

#3 Updated by Teemu Murtola over 5 years ago

  • Assignee changed from Berk Hess to Roland Schulz
  • Target version changed from future to 5.0

Also available in: Atom PDF