Project

General

Profile

Feature #1370

regressiontests/freeenergy fail (timeout) on arm

Added by Christoph Junghans almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
testing
Target version:
Difficulty:
uncategorized
Close

Description

<https://bugs.gentoo.org/show_bug.cgi?id=472124#c6>

Basically the freeenergy tests take too long and cmake kills them after 1500 secs, which lead to a fail.

Associated revisions

Revision 9530952c (diff)
Added by Mark Abraham over 6 years ago

Fix tests that were unstable or too long

Some freeenergy tests were taking too long.

simple_search_group was unstable, so converted it and simple_search to
be better behaved. The boxes they use are uncomfortably small, so the
cutoffs need to be small also.

relative was also unstable, occasionally failing on bs_nix1004 and
another Jenkins slave around step 17. That suggests the step 10
neighbour search was not reproducible enough.

Also shortened the freenergy/relative simulation
(keeping nstdhdl with at least two nstlist calls between).

Fixes #1370

Change-Id: I14c8414dd03ba340babe289bc0860fe89e803f3c

History

#1 Updated by Mark Abraham almost 7 years ago

These run 40-100 steps each, compared with the max of 20 found in the other grompp.mdp files. If it is reasonable to make these shorter (e.g. half the length), then I am happy to do so. Thoughts, Michael?

#2 Updated by Michael Shirts almost 7 years ago

Sure, to reduce the size, one could do the following:

reduce nstdhdl from 100 to 20 for all of the mdp's that have longer time constants

Reduce nststep from to max 40 in all cases (rather than 60-100).

For restraints, which is a larger system and likely one of the larger costs, reduce nststep to 20.

in general, I'd like to keeo some longer, because there are errors that can show up when dhdl is a larger multiple of nstlist, and we want to get at least one extra line dhdl output beyond the first.

I'm 1) traveling right now and 2) not 100% confident on the process right now for replacing the regression tests in a way that doesn't screw up the build process, so perhaps someone else could make these changes?

#3 Updated by Mark Abraham almost 7 years ago

  • Target version changed from 4.6.4 to 4.6.5

Won't hold 4.6.4 for this, and bumps to regressiontests in the next few weeks in master branch will be quite noisy enough. Will plan to do this fix in release-4-6 after 5.0-beta1, and have it come up then.

#4 Updated by Mark Abraham almost 7 years ago

  • Target version changed from 4.6.5 to 4.6.x

#5 Updated by Alexey Shvetsov almost 7 years ago

I can run tests on cortex-a7 cpu with neon vfp for 4.6.x and 5.0.x

#6 Updated by Erik Lindahl over 6 years ago

  • Tracker changed from Bug to Feature

Changing to a feature. While it is nice if the tests complete sooner, we have never guaranteed that tests should complete within X seconds. The auto-download with CMake was a feature Roland Schulz added, but if that is causing problems our short-term option might be to disable the auto-download :-)

For now I would recommend Gentoo to disable running the extensive regressiontests automatically.

#7 Updated by Roland Schulz over 6 years ago

This has nothing to do with auto-download. The running of the tests time out - not the download. Also the download isn't on by default. It is possible to set the timeout used by ctest (see --timeout or CTEST_TEST_TIMEOUT).

#8 Updated by Mark Abraham over 6 years ago

  • Status changed from New to Resolved
  • Target version changed from 4.6.x to 5.0

This was fixed in https://gerrit.gromacs.org/#/c/3248/ some time ago, but only for release-5-0.

#9 Updated by Rossen Apostolov over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF