Project

General

Profile

Bug #1375

Changing vdwtype leads to change in coulomb potential when coulombtype is RF-Zero

Added by Shun Sakuraba about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
-
Affected version - extra info:
4.6-git
Affected version:
Difficulty:
uncategorized
Close

Description

When coulombtype = Reaction-Field-Zero and vdwtype = cutoff is used, the electrostatic interaction shows extremely high energy
(Coulomb(SR) = 2.05078e+07 at step 0. Note the initial structure in an attached file is well-equilibrated with PME.)
Oddly, when vdwtype = Shift, this problem does not occur.
(Coulomb(SR) = -5.27937e+05 at step 0.)

Steps to reproduce:

grompp_d -f rf.mdp -o test
mdrun_d -deffnm test

conf.gro (2.22 MB) conf.gro Shun Sakuraba, 10/31/2013 07:39 AM
topol.top (745 KB) topol.top Shun Sakuraba, 10/31/2013 07:40 AM
rf.mdp (952 Bytes) rf.mdp Shun Sakuraba, 10/31/2013 07:47 AM

History

#1 Updated by Erik Lindahl over 5 years ago

  • Status changed from New to Closed
  • Priority changed from High to Normal

The attached files produce fine results in the current git branches both of 5.0 and 4.6. Since there was no specific version listed I have not bothered checking, but if it occured it must have been fixed by some earlier patch.

Also available in: Atom PDF