Project

General

Profile

Bug #1450

Two-body Distance anomalously large

Added by joshua layfield over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Low
Category:
mdrun
Target version:
Affected version - extra info:
I have checked this on 4.6.3 as well with the same issues.
Affected version:
Difficulty:
uncategorized
Close

Description

I am trying to include a virtual particle into a simulation so that I can calculate the electric field at the midpoint of a bond. I include the virtual particle by taking an equilibrated structure of my enzymatic system and adding the virtual site using the virtual_sites2 directive. I have confirmed that the inclusion of the virtual particle does not affect the results of an MD trajectory by analyzing structures with and without the virtual particle.
When I try run my simulation the two-body bonded distance is spuriously long.

Initial maximum inter charge-group distances:
two-body bonded interactions: 1.585 nm, LJ-14, atoms 5 13
multi-body bonded interactions: 0.434 nm, Proper Dih., atoms 5 13
Minimum cell size due to bonded interactions: 1.743 nm

The two-body bonded interaction is always ~4x longer than the multi-body bonded distance even though they are both for the same two atoms (which are always CB-CE distances in a MET residue). The multi-body bonded distance is correct based on the given structure file. I am attaching the folder that contains all of the input files.

grompp -f mdi.mdp -c confout.gro -p topol.top
mpirun -np 16 mdrun

are the commands to pre-process and run my original structure file.

./gro-incorporate-virtual.pl confout.gro topol.top e-stat.gro unperturbed.top perturbed.top
grompp -f mdi.mdp -c e-stat.gro -p unperturbed.top
mpirun -np 16 mdrun

are the series of commands to created the updated structure and topology files, pre-process the structures, and start the trajectory. When I run this I get the error that there is no domain decomposition for a minimum cell size of 2.17894 nm. I have asked on the gmx-users list but I have not been able to get any help there.

Thank you.

domain-decomp.tar.gz (5.48 MB) domain-decomp.tar.gz joshua layfield, 03/04/2014 07:15 PM

History

#1 Updated by Mark Abraham over 5 years ago

I asked you on gmx-users why you are treating a beta and gamma carbon as bonded. Is that the reason for observing an anomalous distance?

#2 Updated by joshua layfield over 5 years ago

Mark Abraham wrote:

I asked you on gmx-users why you are treating a beta and gamma carbon as bonded. Is that the reason for observing an anomalous distance?

In MET CB and CE interact through a 1-4 interaction.

Initial maximum inter charge-group distances:
two-body bonded interactions: 1.585 nm, LJ-14, atoms 5 13
multi-body bonded interactions: 0.434 nm, Proper Dih., atoms 5 13
Minimum cell size due to bonded interactions: 1.743 nm

As far as I understand the situation, the anomalously long distance increases the minimum cell size and limits the number of processors that can be used.

#3 Updated by Mark Abraham over 5 years ago

A quick look showed me that you have a [virtual_site2] constructed at 2507 from 2506 and 2505, but there was no [bond] between those two. Perhaps there was a [constraint], I didn't think to look. A virtual particle at the midpoint of a bond between two bonded atoms needs a bond if it is to make sense. Is there one?

Do the two atoms relate to the MET CB and CE and if so in what way?

#4 Updated by joshua layfield over 5 years ago

Mark Abraham wrote:

A quick look showed me that you have a [virtual_site2] constructed at 2507 from 2506 and 2505, but there was no [bond] between those two. Perhaps there was a [constraint], I didn't think to look. A virtual particle at the midpoint of a bond between two bonded atoms needs a bond if it is to make sense. Is there one?

Do the two atoms relate to the MET CB and CE and if so in what way?

The two atoms are the donor and acceptor for a hydride transfer reaction that are located on two different substrates. There should not be a bond between them and I cannot find anything that suggests that is necessary for defining a virtual site along the non-bonded axis between these two atoms.
The two atoms are not related to the MET CB and CE either through bonding or spatial interactions. As I have investigated this further, I think that methionine just tends to have the longest 1-4 distances since the C-S bond lengths are longer than C-C and the C-S-C bond angle is larger than the C-C-C angle.

#5 Updated by Mark Abraham over 5 years ago

joshua layfield wrote:

Mark Abraham wrote:

A quick look showed me that you have a [virtual_site2] constructed at 2507 from 2506 and 2505, but there was no [bond] between those two. Perhaps there was a [constraint], I didn't think to look. A virtual particle at the midpoint of a bond between two bonded atoms needs a bond if it is to make sense. Is there one?

Do the two atoms relate to the MET CB and CE and if so in what way?

The two atoms are the donor and acceptor for a hydride transfer reaction that are located on two different substrates.

Now I'm really confused. Your descriptions have all referred to wanting to measure the field strength at a point along a "bond," yet, the atoms in different substrates surely do not share a [bond] interaction.

There should not be a bond between them and I cannot find anything that suggests that is necessary for defining a virtual site along the non-bonded axis between these two atoms.

Indeed, it is not necessary, but your use of "bond" in your description is perhaps misleading me.

The two atoms are not related to the MET CB and CE either through bonding or spatial interactions. As I have investigated this further, I think that methionine just tends to have the longest 1-4 distances since the C-S bond lengths are longer than C-C and the C-S-C bond angle is larger than the C-C-C angle.

OK, that suggests that someone is screwing up some indexing.

From unperturbed.top

  2505         CA    161    FOD    C4N   2505   0.138800     12.010
  2506         CY    161    FOD     C6   2506   0.225975     12.010
  2507         MW    161    FOD     DU   2507   0.000000      0.000

...

[ virtual_sites2 ]
; site from          func      a
 2507  2506  2505     1     0.50000

The [bonds] setup looks like it could be two carbons in different substrates, but when I tried to see what was going on in conf.gro in VMD, all the atom indices around those numbers were in the folate.

Are you able to reproduce the weird effect with and without the vsite with just NAD+FOL in vacuum? The symptom will now be different (no MET), but finding the problem in a debugger (assuming it exists) will be about a hundred times easier.

#6 Updated by Erik Lindahl over 5 years ago

  • Status changed from New to Feedback wanted
  • Priority changed from Normal to Low

No feedback for two months; Joshua, did you try the things Mark suggested?

#7 Updated by Erik Lindahl over 5 years ago

  • Status changed from Feedback wanted to Closed

Bug closed for lack of feedback. Feel free to reopen when information is added.

Also available in: Atom PDF