Project

General

Profile

Bug #146

Energy Minimization Fails in double precision

Added by Justin M. over 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
High
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

At the URL above, a tar file can be downloaded containing:
aladi.pdb (alanine dipeptide)
digly.pdb (diglycine polypeptide)
triala.pdb (trialanine polypeptide)
runAD.sh (shell script for running alanine dipeptide)
runTAn.sh (for neutral trialanine)
runTAz.sh (for zwitterionic trialanine)
runDGn.sh (for neutral diglycine)
runDGz.sh (for zwitterionic diglycine)
*all run scripts are identical except for the molecule name and the -ter options for pdb2gmx. They also
currently are set up to only run the production runs in double precision (which is the setup that actually
runs) But, if you replace all the gromacs programs with their double precision *_d options, then energy
minimization fails.

In step 0 of energy minimization in double precision, we find that the force is infinite on (apparently)
random atoms. Sometimes in the peptide, sometimes in the water that solvates it. The molecules are
not overlapping (so genbox_d seems to be working okay). These are run with the unmodified G43a1
force field, and it seems evident that the force field has something to do with it, as the zwitterionic
species will run using ffG43a2, but not a1 - and the neutral species seems to run with ffG43a1, but not
a2. Also, surprisingly the box size has something to do with it.

I have managed to get both the neutral species to run by using smaller box sizes, which I know seems
strange. I haven't gotten any of the zwitterionic species or the alanine dipeptide to run with double
precision. This same error occurs when running an 88kDa protein, but I did not include those input files
for space/time saving reasons.

History

#1 Updated by David van der Spoel over 12 years ago

Unfortunately the first test I did (runAD.sh) crashes at the pdb2gmx stage due to:

Program pdb2gmx, VERSION 3.3.1
Source code file: /Users/spoel/GROMACS/release-3-3-patches/gmx/src/kernel/resall
.c, line: 438

Fatal error:
Residue 'NME' not found in residue topology database

Apparently you have updated the rtp files. Can you put these in the tar file as
well?

#2 Updated by David van der Spoel about 12 years ago

Justin,

could you upload a tpr that gives these problems in double but not in single? You could also send one single and one double prec. tpr, if otherwise identical.

#3 Updated by David van der Spoel about 12 years ago

After doing several tests in single and double precision I conclude that EM gives basically the same result. Your issue could have been caused by very weird starting coordinates or by a compilation problem. Since I can not reproduce it I am closing this bug. Feel free to reopen if you have tpr files that can reproduce the problem.

Also available in: Atom PDF