Project

General

Profile

Bug #1520

tng include/library/linking problems

Added by Mark Abraham over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
build system
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

There are some messy issues with the way we build and then manage the TNG libraries.

For example, the mdrun-only build currently installs some TNG libraries, which it should not. In principle, the normal build should not install these shared libraries if there is an existing TNG installation, but we can defer solving that part until after 5.0.

Using GMX_INSTALL_PREFIX with a normal build is also broken with TNG, because TNG doesn't get told about the new installation location for its header file.

Some of these issues are related to the way GROMACS re-manages (over-manages?) things like CMAKE_INSTALL_LIBDIR via GMX_LIB_INSTALL_DIR to LIB_INSTALL_DIR. For a component like TNG, which is intended also to build alone, to survive this treatment, it needs to get told where it will install in CMAKE_INSTALL_LIBDIR. I think that means the TNG build should be done external project, which I will try shortly.


Related issues

Related to GROMACS - Bug #1453: tng_io installation issuesClosed03/05/2014

Associated revisions

Revision ef40a754 (diff)
Added by Magnus Lundborg over 5 years ago

Update TNG build system

GROMACS can now find and use a copy of TNG installed on the system.
The default is still to compile the version shipped with GROMACS.
That compilation is now handled using the BuildTNG.cmake script, so
there is no duplication between the GROMACS and TNG CMake code that
builds TNG, and the result is fully portable with all supported
environments and CMake versions.

Moved TNG handling into src/gromacs/CMakeLists.txt where it is
actually used.

Bumped the version of the TNG library to 1.6. Corresponds to commit
ba9aea42b01 in the TNG repository.

Renamed md5 things with GROMACS prefixes, so that there is no internal
name clash with the md5 things in TNG, and no client of libgromacs can
get unexpected behaviour.

Updated GMX_USE_TNG=off to work, and silenced unused-parameter
warnings associated with that setting.

Refs #1453 (partial fix)
Fixes #1520

Change-Id: I7ac9b578e45b8e75c67c9df9440eed968a3a9371

History

#1 Updated by Rossen Apostolov over 5 years ago

Yes, TNG should be treated as external project. Could we always compile GROMACS statically against the shipped TNG and thus there won't be any need to install the libraries?

#2 Updated by Mark Abraham over 5 years ago

Rossen Apostolov wrote:

Yes, TNG should be treated as external project. Could we always compile GROMACS statically against the shipped TNG and thus there won't be any need to install the libraries?

It turns out that there's no good, platform-portable, CMake-version-portable way to do anything like this, and definitely none that can use the TNG repo as it is right now. Fix uploaded.

#3 Updated by Gerrit Code Review Bot over 5 years ago

Gerrit received a related patchset '1' for Issue #1520.
Uploader: Mark Abraham ()
Change-Id: I63477b5d159be7316ba9359a214b7a7145e2d426
Gerrit URL: https://gerrit.gromacs.org/3570

#4 Updated by Mark Abraham over 5 years ago

  • Related to Bug #1453: tng_io installation issues added

#5 Updated by Rossen Apostolov over 5 years ago

  • Status changed from New to Fix uploaded

#6 Updated by Gerrit Code Review Bot over 5 years ago

Gerrit received a related patchset '1' for Issue #1520.
Uploader: Mark Abraham ()
Change-Id: Ibc07b8f6f194e5d15c2ac41aca4cdcd41bd0ef9e
Gerrit URL: https://gerrit.gromacs.org/3685

#7 Updated by Gerrit Code Review Bot over 5 years ago

Gerrit received a related patchset '1' for Issue #1520.
Uploader: Teemu Murtola ()
Change-Id: I9dc715586ade94d2993365afbc935cc0246183dc
Gerrit URL: https://gerrit.gromacs.org/3689

#8 Updated by Gerrit Code Review Bot over 5 years ago

Gerrit received a related DRAFT patchset '1' for Issue #1520.
Uploader: Mark Abraham ()
Change-Id: I1d7e2e71363075588ea038034963c742c73800e9
Gerrit URL: https://gerrit.gromacs.org/3706

#9 Updated by Erik Lindahl over 5 years ago

  • Status changed from Fix uploaded to Resolved

#10 Updated by Erik Lindahl over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF