Project

General

Profile

Bug #156

pdb2gmx generate wrong topology with uncorrect named H in pdb

Added by Yang Ye over 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Use attachd pdb which contains NPRO to generate topology with AMBER 99 port from Stanford. The result is additional H1 with +0.312e. The H atoms in the PDB are named according to AMBER's tleap, H2 and H3, which shall be renamed to H1 and H2.

npro.pdb (1.05 KB) npro.pdb problematic PDB file Yang Ye, 06/30/2007 03:53 PM

History

#1 Updated by Yang Ye over 12 years ago

Created an attachment (id=216)
problematic PDB file

#2 Updated by David van der Spoel about 12 years ago

Have you brought this to the attention of the guys at Stanford?

#3 Updated by Yang Ye about 12 years ago

I think this is not force-field specific but about how pdb2gmx deals with h-atoms. Of course, the root cause is the incoherence naming conventions used in PDB files and force fields.

To illustrate more clearly,

The rtp file has following entries.
[ NPRO ]
[ atoms ]
N amber99_39 -0.20200 1
H1 amber99_17 0.31200 2
H2 amber99_17 0.31200 3
...

The structure file to be parsed by pdb2gmx contains
1 N NPRO
2 H2 NPRO
3 H3 NPRO

pdb2gmx doesn't report the missing H1 but just add H1 without deleting H2 or H3. This makes problem if someone is not carefully checking.

#4 Updated by David van der Spoel about 12 years ago

What command line did you use? You probably need to use the -ter flag to pdb2gmx and select "None" for the N-terminus. Please try it and report back.

#5 Updated by Yang Ye about 12 years ago

I have used

pdb2gmx -f npro.pdb

adding -ter results the same.

Only removing NPRO from aminoacid.dat can trigger an ERROR. See below.

Back Off! I just backed up topol.top to ./#topol.top.6#
Processing chain 1 (16 atoms, 1 residues)
There are 1 donors and 1 acceptors
There are 1 hydrogen bonds
Checking for duplicate atoms....
Opening library file /data1/yangye/bin/gmx_share/top/specbond.dat
5 out of 5 lines of specbond.dat converted succesfully
No N- or C-terminus found: this chain appears to contain no protein
Now there are 1 residues with 17 atoms
Making bonds...
Opening library file /data1/yangye/bin/gmx_share/top/aminoacids.dat
-------------------------------------------------------
Program pdb2gmx_s, VERSION 3.3.1
Source code file: add_par.c, line: 221

Fatal error:
Atom H3 not found in rtp database in residue NPRO, it looks a bit like H1
-------------------------------------------------------

#6 Updated by David van der Spoel about 12 years ago

You have to add flag -ignh, since you have already two hydrogens H2, and H3 which are retained without the flag.

#7 Updated by Yang Ye about 12 years ago

i see. Apparently, I don't have any problem with such behavior. The user shall always do the checking.

Also available in: Atom PDF