Project

General

Profile

Bug #162

g_anaeig: Segmentation fault upon reading in eigenvec.trr

Added by ZT Yew about 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Normal
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I have gromacs3.3.1 on Ubuntu 6.06 - installed using synaptic package manager.

I have a receptor (552 residues) bound to a peptide (6 to 9 residues) and I want to investigate the dynamics of just the receptor without the peptide.

I used make_ndx to make an index file with only CA of the receptor.

Then used g_covar to generate the eigenvectors of the covar. matrix, where the input traj (a series of PDB files concat. together with ENDMDL as a seperator) is that of the receptor bound to the peptide. Everything worked fine (or at least there's no error messages.)

Next, Using g_anaeig -v eigenvec.trr -eig eigenvalue.xvg -proj -first 1 -last 10 gives a segmentation fault. (I've tried just g_anaeig -v eigenvec.trr and the same error appears).

complex_frames.pdb.bz2 (1.81 MB) complex_frames.pdb.bz2 Frames of PDB ZT Yew, 09/22/2007 01:40 PM
complex.pdb (597 KB) complex.pdb PDB file used for make_ndx and as topology ZT Yew, 09/22/2007 01:41 PM

History

#1 Updated by David van der Spoel about 12 years ago

Please upload an example and the exact command line to reproduce the problem.

#2 Updated by David van der Spoel about 12 years ago

Without example we can not do anything about this. Please upload one ASAP such that we can investigate possible problems before we release 3.3.2.

#3 Updated by ZT Yew about 12 years ago

Created an attachment (id=239)
Frames of PDB

I've attached a PDB with frames from a trajectory. I did the following as well as the steps I stated in my first post:

1. make_ndx: index file with CA atoms and residues 1-294 only using complex.pdb

2. g_covar: g_covar -f complex_frames.pdb -s Complex.pdb -n index.ndx -o eigenval.out -v eigenvec.trr

3. g_anaeig: g_anaeig -f complex_frames.pdb -s Complex.pdb -n index.ndx -v eigenvec.trr -proj project1_5.out -first 1 -last 5

4. tried g_anaeig -v eigenvec.trr as well

Error is 'Segmentation fault' at the g_anaeig step

I'll attach complex.pdb later

Thanks.

#4 Updated by ZT Yew about 12 years ago

Created an attachment (id=240)
PDB file used for make_ndx and as topology

#5 Updated by David van der Spoel about 12 years ago

I can not reproduce the error.
How is your installation compiled?

#6 Updated by ZT Yew about 12 years ago

Thanks.

I compiled mine using ubuntu package manager.

g_covar works well, but not g_anaeig. Is it then likely to be due some incompatibility?

#7 Updated by ZT Yew about 12 years ago

I installed gromacs3.3.1 on ubuntu 7.04 and tried to repeat with the files I attached and it works.

So its either a problem with a previous installation on ubuntu 6.06 or something to do with the fact (though unlikely) that I tried it with 2000 frames and the file I attached has only 200?

I will attempt to do the analysis with 2000 frames on ubuntu 7.04

Thanks for your help!

#8 Updated by David van der Spoel about 12 years ago

Most likely a compilation issue, but it could also be a rare bug that only shows up on some machines. I have tested it in my Mac and on a Debian box (which previously showed some problems), and I couldn't reproduce it. Obviously we cannot support all possible OS version. But I will try in the lab to install a box with this.

#9 Updated by Berk Hess about 12 years ago

I tried with Suse, AMD64, Gromacs 3.3.1, gcc
and no problems for me either.

Berk.

#10 Updated by Erik Lindahl about 12 years ago

We cannot reproduce this bug. Please reopen it with an alternative/more detailed example if you can reproduce it on another system.

Also available in: Atom PDF