Project

General

Profile

Bug #1702

Segmentation fault g_covar

Added by Fernando Martin over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When I perform a g_covar on a bundle of PDBs, a get a segmentation fault. However, the same command, executed with g_covar of gromacs 4.6.5 works perfectly.

The command line is:

g_covar -f NMR.xtc -s p5c5NEWfit_1.pdb -n -o -v

where NMR.xtc is the bundle of PDBs generated with trjcat:

trjcat -f p5c5NEWfit_?.pdb p5c5NEWfit_??.pdb -o NMR.xtc -settime

NMR.xtc (104 KB) NMR.xtc Bundle of PDBs Fernando Martin, 03/06/2015 10:51 AM
p5c5NEWfit_1.pdb (105 KB) p5c5NEWfit_1.pdb Fernando Martin, 03/06/2015 10:51 AM

History

#1 Updated by Peter Kasson over 4 years ago

  • Status changed from New to Blocked, need info

Trying to reproduce on master:
empty -n and -o arguments will produce an error. Running with:
gmx covar -f NMR.xtc -s p5c5NEWfit_1.pdb -v

Cannot reproduce if I select Protein for lsq fit and for covariance analysis. Program completes successfully.

Can also run successfully on v5.0.2, although the eigenvalue output differs substantially.

At this point, I cannot reproduce the reported error. Can you provide more info?

#2 Updated by Peter Kasson over 4 years ago

  • Assignee set to Peter Kasson

#3 Updated by Berk Hess over 4 years ago

Is this the same issue as #1733 (with number of 3*atoms in the analysis group < #frames), which was fixed for 5.0.5?

#4 Updated by Berk Hess over 4 years ago

  • Status changed from Blocked, need info to Closed

Duplicate of #1733, fixed in 5.0.5.

#5 Updated by Mark Abraham over 3 years ago

  • Target version changed from 5.x to 5.0.5

Also available in: Atom PDF