Project

General

Profile

Bug #1727

g_energy computes zero energy values with GPU

Added by shruti matix over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Using gromacs 5.0.4 on ubuntu 14.04LTS with a GTX 780 graphics card.

After running protein-ligand simulation for 5ns, the log file incorrectly has zero energy values for all other interactions besides protein-protein interaction energy. Therefore, g_energy computes zero energy, if the MD simulation is run on GPU. For example protein-sol, protein-ligand terms are reported as zero. Sample of log file after 5ns, when run on GPU:

Epot (kJ/mol) Coul-SR LJ-SR Coul-14 LJ-14
Protein-Protein -5.34952e+05 5.87772e+04 2.24001e+04 1.97106e+03
Protein-LIG 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
Protein-SOL 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
Protein-rest 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
LIG-LIG 0.00000e+00 0.00000e+00 -2.31495e+02 9.36822e+01
LIG-SOL 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
LIG-rest 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
SOL-SOL 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
SOL-rest 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00
rest-rest 0.00000e+00 0.00000e+00 0.00000e+00 0.00000e+00

Also, creating index groups and recalculating energies gives the same result (i.e 0 energy values).

However, energy values with CPU compute alone are reported correctly as follows:

Epot (kJ/mol) Coul-SR LJ-SR Coul-14 LJ-14
Protein-Protein -3.71234e+04 -3.56640e+03 2.23658e+04 1.96863e+03
Protein-LIG -4.83560e+01 -1.60406e+02 0.00000e+00 0.00000e+00
Protein-SOL -1.22081e+04 -9.70665e+02 0.00000e+00 0.00000e+00
Protein-rest -2.45000e+02 4.48613e+00 0.00000e+00 0.00000e+00
LIG-LIG 1.22436e+02 -1.21079e+01 -2.31954e+02 9.38064e+01
LIG-SOL -3.28865e+01 -3.46725e+01 0.00000e+00 0.00000e+00
LIG-rest -2.87743e-02 -4.00634e-02 0.00000e+00 0.00000e+00
SOL-SOL -4.48286e+05 6.08941e+04 0.00000e+00 0.00000e+00
SOL-rest -2.49492e+04 2.54938e+03 0.00000e+00 0.00000e+00
rest-rest -1.20356e+04 8.39394e+01 0.00000e+00 0.00000e+00

T-Protein  T-non-Protein
2.99899e+02 3.00003e+02

Might be same issue as http://redmine.gromacs.org/issues/1293 (not sure)


Related issues

Related to GROMACS - Bug #1822: mdrun writes broken energy group values to .edr fileClosed
Is duplicate of GROMACS - Bug #1293: energygrps issue with cuda runsClosed06/28/2013

History

#1 Updated by Justin Lemkul over 5 years ago

  • Is duplicate of Bug #1293: energygrps issue with cuda runs added

#2 Updated by Justin Lemkul over 5 years ago

  • Status changed from New to Closed
  • Priority changed from High to Normal

#3 Updated by Justin Lemkul over 5 years ago

From the previous discussion in #1293, a message should be printed to the .log in this case. If this is not true or could be improved, please file a feature request with suggestions for improvements. Closing this bug report as it duplicates a previously closed report.

#4 Updated by Mark Abraham over 5 years ago

Indeed, a cpu-only rerun is needed to get such a decomposition.

#5 Updated by Mark Abraham about 5 years ago

  • Related to Bug #1822: mdrun writes broken energy group values to .edr file added

Also available in: Atom PDF