Project

General

Profile

Bug #180

g_sas with 3.3 and 3.3.2 gives different results

Added by Isabella Daidone almost 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=267)
1 trajectory file with 1 frame containing 50 peptides, 2 .tpr files created with 2 different versions, 1 index file

I have a box with 50 peptides in it.
When I run g_sas I get different results with version 3.3 and version 3.3.2

1) On a single peptide (I chose 1 peptide for surface calculation and 1 peptide as the output - from the index file: 14 14):

with 3.3:
  1. g_sas -f traj1frame.xtc -s topol33.tpr -o area1_33.xvg -n index.ndx #
    0 1.05683 1.53052 2.58735 0
with 3.3.2
  1. g_sas -f traj1frame.xtc -s topol332.tpr -o area1_332.xvg -n index.ndx
    0 0.973462 1.61389 2.58735 0

2) On all peptides (I chose ALL peptides for surface calculation and ALL
peptides as the output - from the index file: 1 1):

with 3.3:
  1. g_sas -f traj1frame.xtc -s topol33.tpr -o area33.xvg
    0 35.3378 40.1608 75.4986 0
with 3.3.2:
  1. g_sas -f traj1frame.xtc -s topol332.tpr -o area332.xvg
    0 37.7036 50.8631 88.5667 0
50peptides.tar (1.56 MB) 50peptides.tar 1 trajectory file with 1 frame containing 50 peptides, 2 .tpr files created with 2 different versions, 1 index file Isabella Daidone, 11/20/2007 02:32 PM
areas.tar (10 KB) areas.tar files with area.xvg files Isabella Daidone, 11/21/2007 06:05 PM
bug180fix.zip (14 KB) bug180fix.zip Fixed source code David van der Spoel, 02/28/2008 12:58 PM

History

#1 Updated by David van der Spoel almost 12 years ago

Hi Isabella, I think this is not a bug. To compare with 3.3.1 you have to add the flag -nopbc. Since 3.3.2 g_sas can take periodic boundary conditions into account. For the single molecule case you get exactly the same results as with 3.3.1 when you use the flag. For the whole system I can not reproduce the old value. That may actualy be wrong instead.

#2 Updated by Isabella Daidone almost 12 years ago

(In reply to comment #1)

Hi Isabella, I think this is not a bug. To compare with 3.3.1 you have to add
the flag -nopbc. Since 3.3.2 g_sas can take periodic boundary conditions into
account. For the single molecule case you get exactly the same results as with
3.3.1 when you use the flag. For the whole system I can not reproduce the old
value. That may actualy be wrong instead.

Dear David,

I see the point for the single peptide case.
Nevertheless, when I type with version 3.3 (or version 3.3.1) "g_sas -h",
it says that by default pbc are taken into account.
is that not true, then?

Regarding the whole system,
I did not get what you mean with "I can not reproduce the old
value. That may actualy be wrong instead".
Do you also get different ASA with version 3.3 and 3.3.2?
I believe in the case of multiple units (like my case) the calculation is more meaningful when pbc are taken into account, right?

thanks

#3 Updated by David van der Spoel almost 12 years ago

OK, I think it is like this:

If you use the -nopbc flag in 3.3.1 and 3.3.2 you get the same result (this is the original routine from Eisenhaber et al.). If you turn on the -pbc (default) the results are different (lower obviously in both cases). Now I am not 100% sure which one is better, but I assume I changed it for a reason, so the new version should be more likely correct. If you can think of any benchmark I would be interested.

#4 Updated by Isabella Daidone almost 12 years ago

Created an attachment (id=268)
files with area.xvg files

#5 Updated by Isabella Daidone almost 12 years ago

(In reply to comment #3)

OK, I think it is like this:

If you use the -nopbc flag in 3.3.1 and 3.3.2 you get the same result (this is
the original routine from Eisenhaber et al.). If you turn on the -pbc (default)
the results are different (lower obviously in both cases). Now I am not 100%
sure which one is better, but I assume I changed it for a reason, so the new
version should be more likely correct. If you can think of any benchmark I
would be interested.

Dear David,

I have calculated SASA for peptide number 49 (in the index file, number 62), which is across the box edge and I have attached the following four files:
1) v3.3 -nopbc
2) v3.3 -pbc

1) and 2) give the same result for phobic, philic and total area (I presume the -pbc option is not really working

3) v3.3.2 -nopbc
4) v3.3.2 -pbc

3) and 4) do not give same results, neither for phobic, philic and total SASA.
The strange thing is that the one with -pbc gives a higher value for the total SASA than when I do -nopbc.

Another thing is that 3) and 1) are not the same in my case. I hope you will be able to reproduce these results.

I've checked another thing.
If I chose a peptide in the middle of the box (chain 23) and run g_sas with v3.3.2 with and whitout -pbc, I get the same value for the total SASA, but different values for phobic and philic.
this is strange, no?

thanks

Isabella

#6 Updated by David van der Spoel over 11 years ago

Created an attachment (id=274)
Fixed source code

Unpack this zip file, drop the source code in src/tools and recompile. This reproduces the original numbers both with and without PBC. That probably means the example is not good for testing PBC.

#7 Updated by David van der Spoel over 11 years ago

Fixed.

Also available in: Atom PDF