Project

General

Profile

Task #1992

mdrun should not advise users of things that don't matter

Added by Mark Abraham over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
mdrun
Target version:
Difficulty:
uncategorized
Close

Description

At https://mailman-1.sys.kth.se/pipermail/gromacs.org_gmx-users/2016-June/106482.html the advice from mdrun upon restart that the number of nodes is different was confusing to a user, and meant that they didn't focus on the real problem.

There are many ways in which ostensibly equivalent mdrun calls will differ, so we should not differentiate a restart on a different number of ranks, or a different build of GROMACS, as something a user needs to know about. There's no case where they need to take action, and it's not likely to be an accident of concern, either. Since the restart always writes the information about mdrun (even when appending) there is no (longer) any need to say anything about version/build/build user/parallelism mismatch.

Associated revisions

Revision 2d884394 (diff)
Added by Berk Hess over 3 years ago

Remove warnings on checkpoint mismatch

mdrun now only warns for mismatch in minor version, build or
number of ranks used when reproducibility is requested.
Also added a separate message for not matching precision.

Fixes #1992.

Change-Id: Ia20e6beff86484f0b70148c155cdb53fed012136

History

#1 Updated by Gerrit Code Review Bot over 3 years ago

Gerrit received a related patchset '1' for Issue #1992.
Uploader: Berk Hess ()
Change-Id: Ia20e6beff86484f0b70148c155cdb53fed012136
Gerrit URL: https://gerrit.gromacs.org/5962

#2 Updated by Berk Hess over 3 years ago

  • Status changed from New to Fix uploaded
  • Assignee changed from Mark Abraham to Berk Hess
  • Target version set to 2016

Uploaded a fix. But I kept the major version mismatch warning, since we don't guarantee that to work.

#3 Updated by Mark Abraham over 3 years ago

Berk Hess wrote:

Uploaded a fix. But I kept the major version mismatch warning, since we don't guarantee that to work.

Good. Now the stderr has more like

Reading checkpoint file state.cpt generated: Sun Jun 19 11:42:59 2016

  Version mismatch,
    current program: 2016-beta2-dev-20160616-67745cd
    checkpoint file: VERSION 5.1.3-dev-20160617-5833198

The current GROMACS major version is not identical to the one that
generated the checkpoint file. In principle GROMACS does not support
continuation from checkpoints between different versions, so we advise
against this. If you still want to try your luck we recommend that you use
the -noappend flag to keep your output files from the two versions separate.
This might also work around errors where the output fields in the energy
file have changed between the different versions.

which seems fine

#4 Updated by Mark Abraham over 3 years ago

  • Status changed from Fix uploaded to Resolved

#5 Updated by Berk Hess over 3 years ago

#6 Updated by Mark Abraham over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF