Project

General

Profile

Bug #2026

pdb2gmx says it reads multiple *.c.tdb but that is not honored

Added by Chris Neale about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When more than one *.c.tdb file exists, pdb2gmx "reads" the additional file but does allow the use of the options specified therein.

test:
A. Use oplsaa.ff
B. modify aminoacids.c.tdb to only contain [ None ] and [ GLY-COO- ] and [ COO- ] entries while new file aminoacids_more.c.tdb contains the remainder

RESULT:

with regular oplsaa.ff:
Select end terminus type for GLU-3
0: COO-
1: ZWITTERION_COO- (only use with zwitterions containing exactly one residue)
2: COOH
3: None

with the modified folder:
Select end terminus type for GLU-3
0: COO-
1: None

This happens even though with the modified folder gmx pdb2gmx outputs:
Opening force field file /nh/nest/u/cneale/exe/GROMACS/exec/gromacs-5.1.2/serial/share/gromacs/top/oplsaa_mod.ff/aminoacids.c.tdb
Opening force field file /nh/nest/u/cneale/exe/GROMACS/exec/gromacs-5.1.2/serial/share/gromacs/top/oplsaa_mod.ff/aminoacids_more.c.tdb

There is an obvious workaround, which is to have only one *.c.tdb file. However, if gromacs will only allow one then it should not say it is reading the other and, ideally, gromacs would either faithfully read and allow use of the other or throw an error if there is more than one *.c.tdb. I presume this also holds for *.n.tdb but I did not check. The reason to desire multiple tdb files is when adding new options to an existing force field then one does not pollute the original with the addition, thus making it cleaner to share modifications without one having to test that there were no undesired additions/deletions to the file.

Associated revisions

Revision 61e5b736 (diff)
Added by Erik Lindahl over 1 year ago

Don't require matching names between rtp and tdb files

This was only documented in the source. It's a remnant
from the days when all force fields were in the same
directory, and no longer necessary. With this change we
will properly match all termini to all amino acids.

Fixes #2026, #2027.

Change-Id: Ie7bf8e65892281cc2744146a5525be0c4afdcecf

History

#1 Updated by Erik Lindahl over 1 year ago

Technically this was not caused by ignoring additional files, but a requirement that the base names need to match between the file with the RTP and TDB entries.

#2 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '1' for Issue #2026.
Uploader: Erik Lindahl ()
Change-Id: gromacs~release-2018~Ie7bf8e65892281cc2744146a5525be0c4afdcecf
Gerrit URL: https://gerrit.gromacs.org/7406

#3 Updated by Erik Lindahl over 1 year ago

  • Status changed from New to Fix uploaded

#4 Updated by Mark Abraham over 1 year ago

  • Category set to preprocessing (pdb2gmx,grompp)
  • Assignee set to Erik Lindahl
  • Target version set to 2018

#5 Updated by Erik Lindahl over 1 year ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Erik Lindahl over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF