Project

General

Profile

Bug #2077

Grompp shows no warning when reading redundant dih. parameters for the same atomtype from different .itp files.

Added by Elton Carvalho about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

If more than one file #included in the .top define parameters for the same type 9 dihedral, grompp throws no warning about overriding these parameters. Thus, the parameters effectively being used in the run are unclear to the user. grompp only throws warnings when the repeated dihedrals are on the same file.

As a minimal working example consists in #including in a .top twice the same file, which contains [ dihedraltypes ] directives with type 9 dihedrals in it.
Running grompp with a .top file constructed that way only throws warnings when the dihedrals are repeated in the same file.

The expected behavior (according to the documentation and the warning text) would be a warning that all dihedral definitions are being overriden when reading the second copy of the #include, since they are type 9 dihedrals involving the same 4 atomtypes in non-adjacent lines.

The attached tarball contains a charmm forcefield directory and a ddt.prm file defines a few dhedraltypes as type 9. The ddt.top file includes the ddt.prm file and then its identical copy ddt2.prm. Running grompp -f em.mdp -c cube.gro -p ddt.top throws two warnings. Commenting out the second and third multiplicities of the given dihedral eliminates the warnings.

dihedrals.tar.bz2 (261 KB) dihedrals.tar.bz2 Minimal test case Elton Carvalho, 11/15/2016 07:34 PM

Associated revisions

Revision 6b3b7474 (diff)
Added by Berk Hess almost 3 years ago

Disallow overwriting of dihedral type 9

It is no longer allowed to repeat blocks of parameter of multiple
lines for dihedrals of type 9. It is also no longer allowed to
override parameters or dihedrals of type 9. Both are too complex
to properly check. It is still allowed to repeat parameters blocks
consisting of a single line.
Repeating a block with the same parameters would lead to incorrect
dihedral potentials and forces.

Fixed bug in arrayref.h interfaces.

Fixes #2077.

Change-Id: I802c6714a9700744df4e6b5ea96e41aa82793388

History

#1 Updated by Berk Hess almost 3 years ago

  • Status changed from New to Accepted

The expected behavior would actually be no warnings at all, as grompp does not warn when parameters are listed multiple times with exactly the same values. The real issue here is that including the file twice leads to different dihedral parameters.
The construct of assigning multiple parameter lines to the same dihedral is asking for trouble...

#2 Updated by Gerrit Code Review Bot almost 3 years ago

Gerrit received a related patchset '1' for Issue #2077.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2016~I802c6714a9700744df4e6b5ea96e41aa82793388
Gerrit URL: https://gerrit.gromacs.org/6369

#3 Updated by Berk Hess almost 3 years ago

  • Status changed from Accepted to Fix uploaded
  • Assignee set to Berk Hess
  • Target version set to 2016.2

I have pushed up a fix that no longer allows repeating (blocks of) parameters for dihedral type 9, since this is too difficult to support safely.

#4 Updated by Gerrit Code Review Bot almost 3 years ago

Gerrit received a related patchset '1' for Issue #2077.
Uploader: Berk Hess ()
Change-Id: gromacs~master~I802c6714a9700744df4e6b5ea96e41aa82793388
Gerrit URL: https://gerrit.gromacs.org/6374

#5 Updated by Berk Hess almost 3 years ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Mark Abraham almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF