Project

General

Profile

Bug #210

when g_order is used for tetrahedrality order, but all outputing results is zero.

Added by tuyusong empty about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

when g_order is used for tetrahedrality order, but all outputing results is zero.

1. checking the src file: src/tools/gmx_order.c
2. the problem is
The key code lines have been annotated:
The 170-171 lines of the src file look like:
/* sgmol[i] += 3*cost2/32;
sgmol[i] += cost2; /
3. the possible modification
/
sgmol[i] += 3*cost2/32; */
sgmol[i] += cost2;

This is a trivial bug.
Yusong Tu.

History

#1 Updated by Erik Lindahl about 11 years ago

Sorry for not seeing this; apparently my search filter doesn't show "unconfirmed" bugs by default...
I'm not 100% what this fix actually does, but it makes sense that something should go in sgmol[i], so I've committed it.

Also available in: Atom PDF