Project

General

Profile

Bug #2112

Rerun tests with MSVC may expose existing bug

Added by Mark Abraham almost 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

While testing https://gerrit.gromacs.org/#/c/5435/, only on MSVC 2015, dvdl_nonlin[efptCOUL] in sum_dhdl in force.cpp contains garbage on non-NS steps. Presumably that's read of invalid memory. Happens for the nonanol test case used in FreeEnergyMdrun_WithinTolerances_IsReproducedByRerun with all three integrators tested (md, vv, sd).

tpr below created with 5.1.3 via gmx grompp -p nonanol_vacuo.top -c nonanol_vacuo.gro -n nonanol_vacuo.ndx -o nonanol_vacuo -f FreeEnergyMdrun_WithinTolerances_IsReproducedByRerun_0_input.mdp -maxwarn 1 (suppressing the warning about not using md for the nearly decoupled state; which isn't relevant here because sd has the same issue). I haven't yet tested that I can reproduce the issue on Windows with this .tpr

nonanol_vacuo.tpr (13.7 KB) nonanol_vacuo.tpr 5.1.3 tpr Mark Abraham, 02/02/2017 01:28 PM
possible-windows-bug.tgz (7.42 KB) possible-windows-bug.tgz grompp inputs Mark Abraham, 02/02/2017 01:28 PM

Related issues

Related to GROMACS - Task #1868: implement mdrun -rerun better, simplifying do_mdClosed

Associated revisions

Revision b70481d1 (diff)
Added by Mark Abraham about 1 year ago

Re-implemented mdrun -rerun tests

Used the new infrastructure to let the rerun test check that the
energies and trajectories (including forces) produced by a rerun
actually match those produced by a normal mdrun. Such a test running
in parallel would have prevented #1868, and will help checking that
any changed or new integrator functionality does the job that it
should do.

Updated some infrastructure to not care whether it gets passed
a C or C++ string.

Removed small pieces of infrastructure originally intended for use by
this patch but which are no longer required.

Refs #1868, #2112

Change-Id: Ifcb211aba62ccb79ebaec21a3088c9e60a618c86

History

#2 Updated by Mark Abraham over 2 years ago

http://jenkins.gromacs.org/job/Gromacs_Gerrit_master_nrwpo/2617/OPTIONS=gcc-5.2%20openmp%20opencl%20simd=avx_128_fma%20amdappsdk-3.0%20host=bs_nix-amd_gpu,label=bs_nix-amd_gpu/testReport/junit/(root)/freeenergy/transformAtoB/

-------------------------------------------------------
Program:     gmx mdrun, version 2017-dev-20170215-9ef0c76
Source file: src/gromacs/mdlib/sim_util.cpp (line 713)
MPI rank:    0 (out of 2)

Fatal error:
The total potential energy is -nan, which is not finite. The LJ and
electrostatic contributions to the energy are 3039.87 and -nan, respectively.
A non-finite potential energy can be caused by overlapping interactions in
bonded interactions or very large or NaN coordinate values. Usually this is
caused by a badly or non-equilibrated initial configuration or incorrect
interactions or parameters in the topology.

For more information and tips for troubleshooting, please check the GROMACS
website at http://www.gromacs.org/Documentation/Errors
-------------------------------------------------------

#3 Updated by Mark Abraham almost 2 years ago

  • Related to Task #1868: implement mdrun -rerun better, simplifying do_md added

#4 Updated by Mark Abraham over 1 year ago

  • Status changed from New to Closed

I am not seeing this any more with the aforementioned patch's successor (https://gerrit.gromacs.org/#/c/7742/), so perhaps the fix for #2244 helped here.

Also available in: Atom PDF