Project

General

Profile

Feature #2116

Intel compilers 16 + gcc 5 incompatilibity

Added by Szilárd Páll over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
build system
Target version:
Difficulty:
simple
Close

Description

It seems that Intel Compilers 16.0 previous to Update 3 are not compatible with gcc 5. Given that this gcc release is a rather popular one, we might want to add a early build-system check to shield users from the compile-time errors.

Description of the issue is here: https://software.intel.com/en-us/forums/intel-c-compiler/topic/591174

Associated revisions

Revision 9ba0cb8e (diff)
Added by Mark Abraham almost 2 years ago

Update tests for C++11 compiler and standard library

We've started using some more features, so broaden the
range of things for which we check at cmake time.

Also made an explicit error message for older icc that can't handle
newer gcc standard libraries, since this might come up a few times.

Fixes #2116

Change-Id: I3656edb3f7e6f81bbf6ed3ed764bcac56802f87f

History

#1 Updated by Mark Abraham over 2 years ago

Insulating users from this kind of thing is one of the reasons we already check that the standard library works, after we check that the C++ compiler works. (But we can probably find some new things to go in that test.) I imagine it catches this case. (I remember noting that icc 17 worked with gcc 5 when I installed it some time...)

We don't really have a way to tell the version of gcc from which the user is getting the stdlib, so the only thing I can suggest is that when that test fails with icc before 16.0.3, we recommend 16.0.3+, or to use their icc with an earlier version of gcc (but still 4.8.1+)

#2 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #2116.
Uploader: Mark Abraham ()
Change-Id: gromacs~master~I3656edb3f7e6f81bbf6ed3ed764bcac56802f87f
Gerrit URL: https://gerrit.gromacs.org/6463

#3 Updated by Mark Abraham almost 2 years ago

  • Status changed from New to Resolved

#4 Updated by Mark Abraham almost 2 years ago

  • Target version set to 2018

#5 Updated by Mark Abraham almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF