Project

General

Profile

Bug #2117

OPLS/AA HISE residue has non-integer charge in Gromacs 5.1.4

Added by Oliver Stueker almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I've just tried to follow along Justin's Lysozyme tutorial with Gromacs 5.1.4 and noticed that the generated topology has a non-integer charge (qtot 7.887).

Looking at the topology the HIS15 residue seems to be the cause:

; residue  15 HIS rtp HISE q -0.1
   229   opls_238     15    HIS      N     75       -0.5    14.0067   ; qtot 3.5
   230   opls_241     15    HIS      H     75        0.3      1.008   ; qtot 3.8
   231  opls_224B     15    HIS     CA     75       0.14     12.011   ; qtot 3.94
   232   opls_140     15    HIS     HA     75       0.06      1.008   ; qtot 4
   233   opls_505     15    HIS     CB     76     -0.005     12.011   ; qtot 3.995
   234   opls_140     15    HIS    HB1     76       0.06      1.008   ; qtot 4.055
   235   opls_140     15    HIS    HB2     76       0.06      1.008   ; qtot 4.115
   236   opls_507     15    HIS     CG     77     -0.015     12.011   ; qtot 4.1
   237   opls_511     15    HIS    ND1     77      -0.49    14.0067   ; qtot 3.61
   238   opls_508     15    HIS    CD2     78      0.015     12.011   ; qtot 3.625
   239   opls_146     15    HIS    HD2     78      0.115      1.008   ; qtot 3.74
   240   opls_506     15    HIS    CE1     79      0.182     12.011   ; qtot 3.922
   241   opls_146     15    HIS    HE1     79      0.115      1.008   ; qtot 4.037
   242   opls_503     15    HIS    NE2     80      -0.57    14.0067   ; qtot 3.467
   243   opls_504     15    HIS    HE2     80       0.42      1.008   ; qtot 3.887
   244   opls_235     15    HIS      C     81        0.5     12.011   ; qtot 4.387
   245   opls_236     15    HIS      O     81       -0.5    15.9994   ; qtot 3.887
<pre>

Gromacs was retrieved from ftp://ftp.gromacs.org/pub/gromacs/gromacs-5.1.4.tar.gz at 2017-02-07 15:16:12 UTC.

I'm attaching the input .pdb, the generated .gro, topol.top and the output of pdb2gmx.
1AKI_pdb2gmx_out.txt (18.3 KB) 1AKI_pdb2gmx_out.txt program output Oliver Stueker, 02/07/2017 09:30 PM
1AKI.pdb (114 KB) 1AKI.pdb input to pdb2gmx Oliver Stueker, 02/07/2017 09:30 PM
1AKI_processed.gro (96.5 KB) 1AKI_processed.gro generated .grp Oliver Stueker, 02/07/2017 09:30 PM
topol.top (567 KB) topol.top generated topology Oliver Stueker, 02/07/2017 09:31 PM

Related issues

Is duplicate of GROMACS - Bug #2013: Atomic charge of HISD and HISE for OPLS-AA/LClosed

History

#1 Updated by Oliver Stueker almost 3 years ago

I assume this is related to issue #2013 .

There was no problem when I've tried it with Gromacs 5.1.2.

#2 Updated by Mark Abraham almost 3 years ago

  • Status changed from New to Resolved
  • Target version set to 5.1.5

Yes, that's #2013 and has been fixed for 5.1.5 (whenever we decide to do that), but in the meantime you can get the fixed share/top/oplsaa.ff/aminoacids.rtp file e.g. from the 2016.2 release, or just use the whole forcefield folder from 2016.2.

The charges in 5.1.2 have other problems (see http://manual.gromacs.org/documentation/5.1.4/ReleaseNotes/release-notes.html#fixed-opls-aa-l-charges-for-hisd-and-hise)

#3 Updated by Mark Abraham almost 3 years ago

  • Is duplicate of Bug #2013: Atomic charge of HISD and HISE for OPLS-AA/L added

#4 Updated by Mark Abraham over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF