Project

General

Profile

Bug #2236

FEP calculation with flat bottom restraints

Added by Vikas Dubey over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Simulation crashes on multiple nodes while running FEP calculations with flat-bottom restraints on ions of my system. I use gromacs 5.1.2. I have tried simulation on my PC as well. Commands and results are shown below :

with FB restraints
------------------------------------------------
gmx mdrun -deffnm md_17 -v -nt 24 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 30 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 32 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 36 : Crashes
gmx mdrun -deffnm md_17 -v -nt 32 : Crashes


without_FB restraints (with normal restraints)
---------------------------------------------------

gmx mdrun -deffnm md_17 -v -nt 24 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 30 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 32 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 36 : Runs fine
gmx mdrun -deffnm md_17 -v -nt 48 : Runs fine

eq_FB.tpr (11.4 MB) eq_FB.tpr with flat-bottom restraints Vikas Dubey, 08/24/2017 05:57 PM
eq_normal_restraint.tpr (11.4 MB) eq_normal_restraint.tpr with normal restraints Vikas Dubey, 08/24/2017 05:57 PM

Related issues

Is duplicate of GROMACS - Bug #2095: Seg Fault when running flat-bottom position restraints with MPIClosed

Associated revisions

Revision 62827ffd (diff)
Added by Mark Abraham over 2 years ago

Fix flat-bottomed position restraints with multiple ranks

Reallocation was never done for flat-bottomed restraints,
so the indexing could go out of range, leading to segfaults.

Fixes #2236

Change-Id: I866f96684fc5a2fef6391ed62a70abdaa1581a33

History

#1 Updated by Mark Abraham over 2 years ago

  • Status changed from New to Accepted

Confirmed that eq_FB segfaults quickly, with 5.1.2 + multiple ranks GPU (and even with -notunepme -dlb no) but a single rank seems OK.

@Vikas This is technically not an issue with multiple nodes, but with multiple ranks - your runs are using thread-MPI, which by definition can't use multiple nodes.

#2 Updated by Mark Abraham over 2 years ago

I can also reproduce with mdrun -ntmpi 8 -nb cpu so, (as I speculated on gmx-users) the issue is related to parallelism over ranks, and not with GPUs. That it sometimes runs is probably related to where the domain boundaries fall in practice, relative to the atoms involved in the restraints.

#3 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #2236.
Uploader: Mark Abraham ()
Change-Id: gromacs~release-5-1~I866f96684fc5a2fef6391ed62a70abdaa1581a33
Gerrit URL: https://gerrit.gromacs.org/6866

#4 Updated by Mark Abraham over 2 years ago

  • Status changed from Accepted to Resolved

#5 Updated by Mark Abraham over 2 years ago

  • Is duplicate of Bug #2095: Seg Fault when running flat-bottom position restraints with MPI added

#6 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF