Project

General

Profile

Bug #2256

grompp floating point exception with Andersen thermostat

Added by Marvin Bernhardt over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
likely any verion with Andersen massive
Affected version:
Difficulty:
uncategorized
Close

Description

I get a "Floating point exception (core dumped)" message from gmx grompp (version 2016.3) with the following files. The error could be reproduced on a different computer.

This might be related to the Anderson thermostat but I'm not sure. Interestingly i could grompp and mdrun the simulation with a gromacs 4.6.7 installation.

The full output of gmx grompp -debug is:

Will write debug log file: gmx.debug

NOTE 1 [file grompp.mdp, line 28]:
  grompp.mdp did not specify a value for the .mdp option "cutoff-scheme".
  Probably it was first intended for use with GROMACS before 4.6. In 4.6,
  the Verlet scheme was introduced, but the group scheme was still the
  default. The default is now the Verlet scheme, so you will observe
  different behaviour.

Back Off! I just backed up mdout.mdp to ./#mdout.mdp.3#
Setting the LD random seed to -602093053
Generated 330891 of the 330891 non-bonded parameter combinations
Generating 1-4 interactions: fudge = 0.5
Generated 330891 of the 330891 1-4 parameter combinations
Excluding 3 bonded neighbours molecule type 'CHA'
Setting gen_seed to 216421358
Velocities were taken from a Maxwell distribution at 300 K
Removing all charge groups because cutoff-scheme=Verlet
checking 91 functypes
Analysing residue names:
There are:     2      Other residues
Analysing residues not classified as Protein/DNA/RNA/Water and splitting into groups...

NOTE 2 [file grompp.mdp]:
  Andersen temperature control methods assume nsttcouple = 1; there is no
  need for larger nsttcouple > 1, since no global parameters are computed.
  nsttcouple has been reset to 1

Number of degrees of freedom in T-Coupling group System is 30.00
Determining Verlet buffer for a tolerance of 0.005 kJ/mol/ps at 300 K
Calculated rlist for 1x1 atom pair-list as 2.000 nm, buffer size 0.000 nm
Set rlist, assuming 4x4 atom pair-list, to 2.000 nm, buffer size 0.000 nm
Note that mdrun will redetermine rlist based on the actual pair-list setup
Floating point exception (core dumped)

conf.gro (483 Bytes) conf.gro Marvin Bernhardt, 09/22/2017 05:23 PM
grompp.mdp (376 Bytes) grompp.mdp Marvin Bernhardt, 09/22/2017 05:23 PM
moleculetype.itp (628 Bytes) moleculetype.itp Marvin Bernhardt, 09/22/2017 05:23 PM
topol.top (141 Bytes) topol.top Marvin Bernhardt, 09/22/2017 05:23 PM

Related issues

Has duplicate GROMACS - Bug #2263: Andersen thermostat is applied with wrong frequency/ at the wrong stepClosed

Associated revisions

Revision d36730ca (diff)
Added by Berk Hess over 1 year ago

Fix grompp with Andersen massive and no COM removal

Fixed a floating point exception leading to a segv.
Also fixed possible different rounding for the interval for
Andersen massive in grompp in mdrun for the common case where tau_t
is a multiple of delta_t.

Fixes #2256

Change-Id: I161e8a9db2c31fde8a6e8c2fd32551b21423fd9b

History

#1 Updated by Berk Hess over 1 year ago

  • Subject changed from grompp floating point exception to grompp floating point exception with Andersen thermostat
  • Status changed from New to In Progress
  • Assignee set to Berk Hess
  • Target version set to 2016.5
  • Affected version - extra info set to likely any verion with Andersen massive

The issue is triggered because you are using the combination of Andersen massive with no center of mass motion removal. You can avoid it by turning on center of mass motion removal.
If will push up a fix to gerrit.

#2 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '1' for Issue #2256.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2016~I161e8a9db2c31fde8a6e8c2fd32551b21423fd9b
Gerrit URL: https://gerrit.gromacs.org/6961

#3 Updated by Berk Hess over 1 year ago

  • Status changed from In Progress to Fix uploaded

#4 Updated by Berk Hess over 1 year ago

  • Status changed from Fix uploaded to Resolved

#5 Updated by Berk Hess over 1 year ago

#6 Updated by Mark Abraham over 1 year ago

  • Has duplicate Bug #2263: Andersen thermostat is applied with wrong frequency/ at the wrong step added

#7 Updated by Erik Lindahl over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF