Project

General

Profile

Bug #2263

Andersen thermostat is applied with wrong frequency/ at the wrong step

Added by Sebastian Wingberm├╝hle almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
-
Affected version - extra info:
not yet fixed in 2016.3
Affected version:
Difficulty:
uncategorized
Close

Description

Due to direct data type conversion from float to integer without rounding, the Andersen and Andersen-massive thermostat are a few time steps off the frequency specified in the .mdp file. The problem can be solved by changing one line in update.c (see fix.txt attached below).

fix.txt (989 Bytes) fix.txt Sebastian Wingberm├╝hle, 10/05/2017 05:07 PM

Related issues

Is duplicate of GROMACS - Bug #2256: grompp floating point exception with Andersen thermostatClosed

History

#1 Updated by Mark Abraham almost 2 years ago

  • Is duplicate of Bug #2256: grompp floating point exception with Andersen thermostat added

#2 Updated by Mark Abraham almost 2 years ago

I think we've fixed this already at #2256, which will be in GROMACS 2016.4 in due course. The proposed fix, or the one you can find there will work in earlier versions too.

#3 Updated by Berk Hess almost 2 years ago

  • Status changed from New to Resolved

#4 Updated by Erik Lindahl over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF