Project

General

Profile

Bug #2350

AVX2 with ICC 17 pdb2gmx regressiontests fail

Added by Roland Schulz over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

It fails with:

Index  Reference   This test       Error  Description
  48    -4724.69    -4490.64   0.0253977  6pti.pdb with charmm27 using vsite=none and water=tips3p

Occurs with 17u4 and 17u5 (haven't tested earlier updates). Doesn't seem to happen with 18u1. Also it is fine with without optimization (-DCMAKE_BUILD_TYPE=Debug).
cmake command line used (doesn't seem to depend on any specific flags):
FLAGS="-g";CFLAGS=$FLAGS CXXFLAGS=$FLAGS CC=icc CXX=icpc cmake3 .. -DGMX_FFT_LIBRARY=mkl -GNinja

Tested that the problem occurs in the mdrun step of the test (and not pdb2gmx, editconf, grompp). If I take the tpr file generated with a working version I get the same energy with the failing version.

I'll spend time to try to figure out whether this is a GROMACS bug, a compiler bug, or a too tight test. But any help would be greatly appreciated.

Associated revisions

Revision 9a7f070d (diff)
Added by Roland Schulz over 2 years ago

Simplify CMAP loop

Fixes #2350

Change-Id: Id87a2105012d541f77d1c278029fe36b874328a9

History

#1 Updated by Erik Lindahl over 2 years ago

I have run pretty much daily test builds with icc (ICC) 17.0.4 20170411 on our AVX2 & AVX512 systems, without any problems (just confirmed that it's still fine).

#2 Updated by Roland Schulz over 2 years ago

It doesn't happen with <=4 (t)MPI. Thus if compiled with GMX_MPI=on one needs to run gmxtest.pl with "-np 4" or bigger. If compiled without GMX_MPI (thus tmpi) then it should always appear (if machine has >=4 cores) because the -nt option of gmxtest.pl is ignored for the pdb2gmx test.

#3 Updated by Erik Lindahl over 2 years ago

And it never happens with gcc?

I can help debug it later tonight, but I'll first try to give some love to another handful of semi-ignored old redmine issues :-)

#4 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #2350.
Uploader: Roland Schulz ()
Change-Id: gromacs~release-2018~Id87a2105012d541f77d1c278029fe36b874328a9
Gerrit URL: https://gerrit.gromacs.org/7345

#5 Updated by Roland Schulz over 2 years ago

  • Status changed from New to Resolved

#6 Updated by Erik Lindahl over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF