Project

General

Profile

Bug #242

mdrun reports an error message with position restraint simulations

Added by Mohamed Sherif about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I was doing the speptide tutorial. After I generated .tpr file using grompp for the position restraint (PR) part of the simulation, mdrun reports the following:

Back Off! I just backed up prlog.log to ./#prlog.log.1#
Getting Loaded...
Reading file pr.tpr, VERSION 3.3.1 (single precision)
Loaded with Money

starting mdrun 'Protein in water'
5000 steps, 10.0 ps.

Segmentation fault (core dumped)

However, there was no problem with the EM simulation, or when I tried to run the simulation and bypassing the PR step.

I ran another simulation, with the system consisting of 2 peptide chains and 2 calcium ions bound to one of the peptide chains. Still I get an exact message. The EM simulation ran with no problems. I think that the problem is with something regarding the .tpr generated from .mdp files of PR simulation.

Can you help me with this? Thank you.

History

#1 Updated by Berk Hess about 11 years ago

One other person has reported crashes with position restraints,
but I (and I think also the other developers) have never had problems.
The speptide tutorial runs fine for me.

Could you attach the tpr file?

Did you run this in parallel or single processor?
What machine and compiler are you using?

Berk

#2 Updated by Berk Hess about 11 years ago

For me your tpr file works fine,
both on a intel core2 and amd64 with linux.
I tried several 4.0 rc versions and 4.0 and they all work.

I assume you are using gcc.
Could you type:
gcc --version
and malil the version number?

Could you install the Gromacs 4.0 release (not rc versions),
to see if the problem is also present in the lastest release?

Berk

#3 Updated by Mohamed Sherif about 11 years ago

Thank you again.

This is the output of the command:

gcc (GCC) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

I checked the GROMACS website, and I cannot find except the source code version from the link ftp://ftp.gromacs.org/pub/gromacs/gromacs-4.0.tar.gz This link is found on the overview page. Is there is another link to the release version?

Thank you.

Mohamed.

#4 Updated by Berk Hess about 11 years ago

Maybe my gmx version question was confusing.

Bugzilla only allows you to select version 4.0_rc1.
Do you get the error in 4.0_rc1, an other 4.0_rc? version
or in the official 4.0 release?

At the top of your md.log file you will see something like:
:-) VERSION 4.0 (:
or
:
) VERSION 4.0_rc? (-:

Berk

#5 Updated by Mohamed Sherif about 11 years ago

I am sorry. When I checked the md.log file, it showed that it is 3.3.1. This is strange because I downloaded version 4, may be I made a mistake. However, thanks for the help. I'll let you know as soon as I install ver.4.

#6 Updated by Mohamed Sherif about 11 years ago

Hi,
I made sure that I downloaded the package for GROMACS 4. yet when I checked the md.log file, it said that it is GROMACS 3.3.1. How can this be possible? Some files of the package are mentioning that it is GROMACS 4 (for example: config.log, configure.ac)
Other files are mentioning that it is GROMACS 3.1 (for example: install (saying "Welcome to GROMACS 3.1)). So, I am wondering how can I have this? Thanks for your help.

Mohamed

#7 Updated by Berk Hess about 11 years ago

This sounds like you maybe only compiled 4.0 and did not install it,
or that the two versions are installed in different paths.

You can type:
where mdrun
which will tell you where in your path the operating system
finds mdrun binaries.
You can then execute them with the full path and option -h
to find out which binary belongs to which version.

Berk

#8 Updated by Mohamed Sherif about 11 years ago

Hi,
Thanks alot for your advice. I checked it out, and yes, I had both versions, and it seems that I did not install version 4.

So, I removed the old version, and installed version 4. Right now, things are going fine. I only needed to identify the path for the GMXLIB. That's all :)) And it is working nicely.

Thank you for all of your advices.

Mohamed

Also available in: Atom PDF