Project

General

Profile

Bug #2443

clang 6.0 with CUDA support restrictions

Added by Szilárd Páll over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

clang 6.0 now works with CUDA 9.0, but the CMake code-gen does not respect the sm_20 deprecation.

Associated revisions

Revision 2e3f4854 (diff)
Added by Szilárd Páll over 1 year ago

Fix clang 6.0 with CUDA 9.0

This enables clang 6.0 CUDA build for sm_70 and works around an issue
which seems to affect sm_37 support.

Fixes #2443

Change-Id: Ib9c52e4a3a8ac1e05e851c8166eec4a6b5df4825

History

#1 Updated by Szilárd Páll over 1 year ago

  • Affected version - extra info set to 2016.4

Perhaps it's not worth fixing in v2016, though.

#2 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '1' for Issue #2443.
Uploader: Szilárd Páll ()
Change-Id: gromacs~release-2018~Ib9c52e4a3a8ac1e05e851c8166eec4a6b5df4825
Gerrit URL: https://gerrit.gromacs.org/7667

#3 Updated by Mark Abraham over 1 year ago

Szilárd Páll wrote:

Perhaps it's not worth fixing in v2016, though.

It wasn't supported then ;-)

#4 Updated by Szilárd Páll over 1 year ago

  • Status changed from New to Resolved

#5 Updated by Mark Abraham over 1 year ago

  • Target version set to 2018.1

#6 Updated by Mark Abraham over 1 year ago

  • Affected version - extra info deleted (2016.4)

#7 Updated by Mark Abraham over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF