Project

General

Profile

Bug #2523

Bug in solvate

Added by marc Barbry about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

Hi,

I found a bug regarding bad formatted input pdb file in the solvate package.
Using a pdb file (H2o-nocell.pdb) without any cell indication just lets the program running since it get stuck in a while loop. (solvate.cpp, line ~250).
This is because the variable box[i][i] = 0.0, therefore xcg does not increment.

To reproduce the error, you can run (see attached files)

gmx solvate -cs H2O-nocell.pdb  -cp centered.gro  -p topol.top -o solvated.gro

The input file should be correctly check in order to avoid such issues.

Best regards,
Marc Barbry

gmx-tutorial-material-bug.tar.gz (5.68 MB) gmx-tutorial-material-bug.tar.gz marc Barbry, 05/25/2018 04:58 PM

Associated revisions

Revision a59917f9 (diff)
Added by Paul Bauer about 1 year ago

Disallow use of empty box information in solvent files

An empty box information in a solvent file presented to gmx solvate
could case an infinte loop because the current coordinate would always
be incremented by zero. Disallowed by introducing new function that
checks for proper box information.

Fixes #2523

Change-Id: I461509f8aafa2048253faf85ccbe388bbbaf80a7

History

#1 Updated by Gerrit Code Review Bot about 1 year ago

Gerrit received a related patchset '1' for Issue #2523.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2018~I461509f8aafa2048253faf85ccbe388bbbaf80a7
Gerrit URL: https://gerrit.gromacs.org/7960

#2 Updated by Paul Bauer about 1 year ago

  • Status changed from New to Resolved

#3 Updated by Paul Bauer about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF