Project

General

Profile

Bug #2575

gromacs 2018.2 "gmx rmsf -oq pdb"

Added by Owen Vickery over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

In gromacs 2018.2 with the gmx rmsf tool the bfactors pdb outputted by the -oq flag columns are not correctly aligned, leading to gromacs, vmd and pymol misreading the file.

ATOM 8 HA MET A 0 62.005 67.280 72.658 1.00 55.76
ATOM 9 CB MET A 0 60.965 65.570 71.758 1.00 105.42
ATOM 10 HB1 MET A 0 60.015 65.420 71.218 1.00 146.94
ATOM 11 HB2 MET A 0 61.745 65.280 71.038 1.00 112.41
ATOM 12 CG MET A 0 61.015 64.580 72.968 1.00 133.49
ATOM 13 HG1 MET A 0 61.775 64.930 73.688 1.00 180.07
ATOM 14 HG2 MET A 0 60.095 64.710 73.578 1.00 184.69
ATOM 15 SD MET A 0 61.255 62.800 72.588 1.00 139.99
ATOM 16 1MCE MET A 0 59.915 61.570 71.878 1.00 233.45

bfac-2018-1.pdb (21.9 KB) bfac-2018-1.pdb 2018.1 bfactor Owen Vickery, 07/20/2018 02:34 PM
bfac-2018-2.pdb (754 KB) bfac-2018-2.pdb 2018.2 bfactor Owen Vickery, 07/20/2018 02:34 PM
pal-wt-pe.xtc (485 KB) pal-wt-pe.xtc Owen Vickery, 07/20/2018 02:35 PM
pal-wt-pe.tpr (1.25 MB) pal-wt-pe.tpr Owen Vickery, 07/20/2018 02:35 PM

Associated revisions

Revision c326c8db (diff)
Added by Paul Bauer over 1 year ago

Fix bfactor output

The fix for the PQR file output caused the files containing bfactors to
be incorrectly written in this format due to a missing check that has
been added.

Fixes #2575

Change-Id: I35c3b99fee81db689df9564c3386edd85e26cbb2

History

#1 Updated by Paul Bauer over 1 year ago

Hello, could you add a small example for us to reproduce the exact error? E.g. exact command line input and the corresponding files.
Thanks!

#2 Updated by Owen Vickery over 1 year ago

Hi

here is a tpr file, and short trajectory and a example pdb from 2018.1 and .2.

The command line is :
echo 1 | gmx rmsf -f pal-wt-pe.xtc -s pal-wt-pe.tpr -oq bfac.pdb

#3 Updated by Paul Bauer over 1 year ago

I confirmed this now. It got caused by b0f4bf1d, even though this should have only ever touched PQR file outputs ...

#4 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '1' for Issue #2575.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2018~I35c3b99fee81db689df9564c3386edd85e26cbb2
Gerrit URL: https://gerrit.gromacs.org/8109

#5 Updated by Mark Abraham over 1 year ago

  • Category set to preprocessing (pdb2gmx,grompp)
  • Assignee set to Paul Bauer
  • Target version set to 2018.3

#6 Updated by Paul Bauer over 1 year ago

  • Status changed from New to Resolved

#7 Updated by Paul Bauer over 1 year ago

  • Status changed from Resolved to Closed

#8 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related DRAFT patchset '1' for Issue #2575.
Uploader: Paul Bauer ()
Change-Id: gromacs~master~Id841208171da21743a85159242c4c5221adcb309
Gerrit URL: https://gerrit.gromacs.org/8140

Also available in: Atom PDF