Project

General

Profile

Bug #2714

grompp does not correctly check nstexpanded nstcalcenergy compatibility

Added by Berk Hess about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
likely all versions
Affected version:
Difficulty:
uncategorized
Close

Description

nstexpanded was checking conditionally on ir->efep instead of ir->bExpanded. This might have led to incorrect energies being used for expanded ensemble sampling with free-energy=on and nstexpanded not a multiple of nstcalcenergy. I have not checked if results would actually be wrong in this case.

Associated revisions

Revision e1e38bc3 (diff)
Added by Berk Hess about 1 year ago

Correct grompp nstexpanded/nstcalcenergy check

With expanded ensemble, but without free-energy perturbation, grompp
would not check if nstexpanded was a multiple of nstcalcenergy.
If the latter was not the case, results might have been incorrect.
Also added a check in mdrun to catch old, incorrect tpr files.

Fixes #2714

Change-Id: I554351e2c9873a71efbc6e803134eb744e229f1d

Revision ef48ba37 (diff)
Added by Berk Hess about 1 year ago

Correct VV integrator nstcalcenergy use

With velocity Verlet integrators, mdrun would compute energies
which contribute to averages in the energy output and might be
used for expanded ensemble calculcations one step too late.

Fixes #2718
Refs #2714

Change-Id: I67e4d00f7151ec9eb5dab6ca4e87b81ca12236e2

Revision 626e3818 (diff)
Added by Berk Hess about 1 year ago

Work around expanded ensemble issues

Two bugs could cause expanded ensemble sampling to use
outdated or zero energies. In these cases mdrun now modifies
nstcalcenergy to 1 to avoid these bugs.

Note: This change should not be merged upstream, since there
is a proper fix for release-2019.

Refs #2714
Refs #2718

Change-Id: I79be9c5da55eaebb857bac6a98e6671720532e0e

History

#1 Updated by Gerrit Code Review Bot about 1 year ago

Gerrit received a related patchset '1' for Issue #2714.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2019~I554351e2c9873a71efbc6e803134eb744e229f1d
Gerrit URL: https://gerrit.gromacs.org/8616

#2 Updated by Berk Hess about 1 year ago

  • Status changed from In Progress to Fix uploaded

Michael, could you check if this actually have allowed mdrun to generate incorrect results?
The simtemp regression test is affected by this.

#3 Updated by Gerrit Code Review Bot about 1 year ago

Gerrit received a related patchset '1' for Issue #2714.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2019~I67e4d00f7151ec9eb5dab6ca4e87b81ca12236e2
Gerrit URL: https://gerrit.gromacs.org/8622

#4 Updated by Gerrit Code Review Bot about 1 year ago

Gerrit received a related patchset '1' for Issue #2714.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2018~I79be9c5da55eaebb857bac6a98e6671720532e0e
Gerrit URL: https://gerrit.gromacs.org/8623

#5 Updated by Berk Hess about 1 year ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Mark Abraham about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF