Project

General

Profile

Bug #2747

nb_kernel_ElecEwSw_VdwBhamSw_GeomW4W4 regressiontest failing on Power8

Added by Szilárd Páll 9 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Affected version - extra info:
2019-beta3-dev-20181108-d536de3
Affected version:
Difficulty:
uncategorized
Close

Description

$ bin/gmx -version 
             :-) GROMACS - gmx, 2019-beta3-dev-20181108-d536de3 (-:

                            GROMACS is written by:
     Emile Apol      Rossen Apostolov      Paul Bauer     Herman J.C. Berendsen
    Par Bjelkmar      Christian Blau   Viacheslav Bolnykh     Kevin Boyd    
 Aldert van Buuren   Rudi van Drunen     Anton Feenstra    Gerrit Groenhof  
   Anca Hamuraru    Vincent Hindriksen  M. Eric Irrgang    Aleksei Iupinov  
 Christoph Junghans     Joe Jordan     Dimitrios Karkoulis    Peter Kasson   
     Jiri Kraus      Carsten Kutzner      Per Larsson      Justin A. Lemkul 
   Viveca Lindahl    Magnus Lundborg     Erik Marklund       Pascal Merz    
 Pieter Meulenhoff    Teemu Murtola       Szilard Pall       Sander Pronk   
   Roland Schulz      Michael Shirts    Alexey Shvetsov     Alfons Sijbers  
   Peter Tieleman    Teemu Virolainen  Christian Wennberg    Maarten Wolf   
                           and the project leaders:
        Mark Abraham, Berk Hess, Erik Lindahl, and David van der Spoel

Copyright (c) 1991-2000, University of Groningen, The Netherlands.
Copyright (c) 2001-2018, The GROMACS development team at
Uppsala University, Stockholm University and
the Royal Institute of Technology, Sweden.
check out http://www.gromacs.org for more information.

GROMACS is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1
of the License, or (at your option) any later version.

GROMACS:      gmx, version 2019-beta3-dev-20181108-d536de3
Executable:   /home/pszilard/gromacs-19/build_p8_gcc7_fftw-own_double/bin/gmx
Data prefix:  /home/pszilard/gromacs-19 (source tree)
Working dir:  /home/pszilard/gromacs-19/build_p8_gcc7_fftw-own_double
Command line:
  gmx -version

GROMACS version:    2019-beta3-dev-20181108-d536de3
GIT SHA1 hash:      d536de3b5125b79d4222768e356c4914e0758d5a
Precision:          single
Memory model:       64 bit
MPI library:        thread_mpi
OpenMP support:     enabled (GMX_OPENMP_MAX_THREADS = 64)
GPU support:        disabled
SIMD instructions:  IBM_VSX
FFT library:        fftw-3.3.8
RDTSCP usage:       disabled
TNG support:        enabled
Hwloc support:      hwloc-1.11.8
Tracing support:    disabled
C compiler:         /home/pszilard/programs/gcc/7.3/bin/gcc GNU 7.3.0
C compiler flags:   -mcpu=power8 -mpower8-vector -mpower8-fusion -mdirect-move  -mvsx    -Werror=format-overflow -Wundef -Wextra -Wno-missing-field-initializers -Wno-sign-compare -Wpointer-arith -Wall -Wno-unused -Wunused-value -Wunused-parameter  -O3 -DNDEBUG -funroll-all-loops -fexcess-precision=fast  -Wno-array-bounds 
C++ compiler:       /home/pszilard/programs/gcc/7.3/bin/g++ GNU 7.3.0
C++ compiler flags: -mcpu=power8 -mpower8-vector -mpower8-fusion -mdirect-move  -mvsx    -std=c++11  -Wformat-overflow -Wundef -Wextra -Wno-missing-field-initializers -Wpointer-arith -Wmissing-declarations -Wall  -O3 -DNDEBUG -funroll-all-loops -fexcess-precision=fast  -Wno-array-bounds 
checkforce.out (12.2 KB) checkforce.out Szilárd Páll, 11/08/2018 03:53 PM

Related issues

Related to GROMACS - Bug #2734: regressiontests/kernel core dumps on ppc64leIn Progress
Related to GROMACS - Bug #2746: regressiontests/freeenergy coulandvdwsequential_vdw failing on Power8Closed

Associated revisions

Revision 4a7281ef (diff)
Added by Szilárd Páll 5 months ago

Disable instruction fusion on Power8

The -mpower8-fusion flag seems to be the source of incorrect code; not
confirmed, but likely a codegen issue that also affects Power9 with the
similar flag used.

Fixes #2747 #2746 #2734

Change-Id: I56f50e54db47f4fe30c42488f4c4f79ac474518a

Revision 1ce795fe (diff)
Added by Szilárd Páll 5 months ago

Disable instruction fusion on Power8

The -mpower8-fusion flag seems to be the source of incorrect code; not
confirmed, but likely a codegen issue that also affects Power9 with the
similar flag used.

Fixes #2747 #2746 #2734

Change-Id: I56f50e54db47f4fe30c42488f4c4f79ac474518a

History

#1 Updated by Erik Lindahl 7 months ago

They passed with gcc-8.2 for me, but instead two of the complex tests failed.

#2 Updated by Mark Abraham 7 months ago

  • Target version set to 2019.1

Per #2746, I suggest we stop supporting power8.

Setting a version so that we force ourselves to make a decision.

#3 Updated by Mark Abraham 7 months ago

  • Related to Bug #2734: regressiontests/kernel core dumps on ppc64le added

#4 Updated by Mark Abraham 7 months ago

  • Related to Bug #2746: regressiontests/freeenergy coulandvdwsequential_vdw failing on Power8 added

#5 Updated by Mark Abraham 6 months ago

  • Assignee set to Szilárd Páll

szilard to try to repro any of these that we haven't repro-ed, particularly if they might need a weird toolchain?

#6 Updated by Szilárd Páll 6 months ago

Update: looks like this and possibly #2746 and possibly #2734 may be related to the "-mpower8-fusion" flag. If I remove it, I so far could not reproduce any of the previous failures.

We could just yank that flag and move on. However given that it is a recommended flag by IBM for Power8 (likely Power9 too, though I've not seen public optimization guides yet), users or computer centers will sometimes take such recommendations and pass them in CMAKE_CXX_FLAGS and than we're back to failing tests.
Hence, we should consider checking whether there is something "illegal" we do (WIP Erik) or otherwise try to report the issue.

#7 Updated by Gerrit Code Review Bot 5 months ago

Gerrit received a related patchset '1' for Issue #2747.
Uploader: Szilárd Páll ()
Change-Id: gromacs~release-2019~I56f50e54db47f4fe30c42488f4c4f79ac474518a
Gerrit URL: https://gerrit.gromacs.org/9104

#8 Updated by Gerrit Code Review Bot 5 months ago

Gerrit received a related patchset '1' for Issue #2747.
Uploader: Szilárd Páll ()
Change-Id: gromacs~release-2018~I56f50e54db47f4fe30c42488f4c4f79ac474518a
Gerrit URL: https://gerrit.gromacs.org/9105

#9 Updated by Mark Abraham 5 months ago

  • Status changed from New to Fix uploaded

#10 Updated by Mark Abraham 5 months ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF