Project

General

Profile

Bug #2918

mdrun segfaults with group scheme .tpr

Added by Carsten Kutzner 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

Due to a small glitch, commit ce17e81d93d7416c0e2d "Initial deactivation of group scheme" does not give a fatal error with group scheme .tpr files, but segfaults. The problem is in line 1631 of forcerec.cpp (init_forcerec): the condition "if (fr->cutoff_scheme ecutsGROUP)" can never be true at this point: ecutsGROUP is the second entry in the list of cutoff schemes and will thus be 1. Since fr has just been build using new t_forcerec before entering init_forcerec, its contents will be zero, including fr->cutoff_scheme.

A solution would be to use the condition "if (ir->cutoff_scheme ecutsGROUP)" instead.

A maybe better solution would be to move checking for the group scheme directly after .tpr file reading to runner.cpp:682.

Associated revisions

Revision 8080617f (diff)
Added by Carsten Kutzner 8 months ago

Early exit from mdrun if group scheme is detected in .tpr

Fixes #2918

Change-Id: I37566623c3ed4613f8b4e69f9f74882656772d1d

History

#1 Updated by Carsten Kutzner 8 months ago

  • Assignee set to Carsten Kutzner

#2 Updated by Mark Abraham 8 months ago

  • Status changed from New to Fix uploaded

#3 Updated by Mark Abraham 8 months ago

  • Target version set to 2020-beta1

#4 Updated by Carsten Kutzner 8 months ago

  • Status changed from Fix uploaded to Resolved

#5 Updated by Paul Bauer 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF